My ped is non functioning ,help apreciated

Recently when cruising at around 8k rpm for a long period of time my ped would just cut out , it then started popping and backfiring and lost most power,i checked the plug to find it had broken down. So i replaced it with the correct plug. (not sure if this has anything to do with my new problem)

My ped now will not start by kick or electric , the only way to start it is to bump it , it wont tick over and has lost all power and it no longer has its powerband. The only way to keep it running is to hold it at 6k+ rpm , it still feels like it has compression like before but im not sure if i can hear a slight rattling from the engine ,Any ideas!?

Re: My ped is non functioning ,help apreciated

If you're experiencing top-speed power losses, suspect a too-lean air:fuel mixture.. or too-advanced ignition timing.. or old fuel.. or carbon build up in the head (causing too-high compression or perhaps pre-ignition caused by something that remains red hot and preignites fuel.... perhaps compression ratio itself was made too high (by you or someone else)

Suspect top end overheating due to one or more reasons.

If the problem was not taken care of, some other damage could have ocurred which is responsible for additional troubles, like no-start and no-power... and now it's too late to do a simple plug chop and diagnose the original cause.

btw.. from where are you getting these rpm numbers .. this is a moped?

the last time i mounted a tach on mine, top rpm was around 5,500.

Re: My ped is non functioning ,help apreciated

Leon Swarmer /

Define broken down spark plug please.

Re: My ped is non functioning ,help apreciated

let the engine warm up before jetting correctly. run a plug chop at wot. all the other throttle positions can be adjusted. you might be running way too rich. and some of the gas may be coming out of the pipe and burning in there. another thing maybe incorrect timing or too cold of a plug

Re: My ped is non functioning ,help apreciated

George Smith /

this is the reason i keep everything stock engine wise lol

then again, im not driving my moped for speed :P

Re: My ped is non functioning ,help apreciated

if your plugs (broken down) u sure part of it hasnt dropped into the cylinder while u were riding, thus partically jamming in the piston rings and causing lack of compression at low speeds but not destroying you engine, is possible happened on my old mobylette

Re: My ped is non functioning ,help apreciated

it could be preignition caused by carbon, or just coincidence that the points may be burning due to wear. either could cause the symptoms that you describe.

Re: My ped is non functioning ,help apreciated

Ben Van Zoest /

Sounds like you ran the piss out it, probally shot forever.

By the way....

Ben Van Zoest /

NO profile NO advice..

Re: My ped is non functioning ,help apreciated

Most people think a sparkpug is or say that it is burnt out when it really is fouled up and shorted out ( mostly with two stroke motors). IF YOU ACTUALLY SEE A BURNT PLUG, then something serious is wrong ,usually a burnt piston or seized piston. When the piston seizes it cools off and is loose again but the rings get stuck and you loose compression so you don't have any power. The brand of bike, model and 4 or 2 stroke is very helpfull in diagnosing problems

Re: My ped is non functioning ,help apreciated

if your plug truley was burn't, you may have burned a small hole in your piston. That would cause a compression loss, but not enough to keep it from running totally.

do a compression check and tell up how many PSI you get after 5 kicks, don't forget to open the carb up all the way when you do it.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account