Can't get it started up! help!

Got a used Garelli Moped , not sure exactly what year it is but somewhere around late 70's early 80's.

Can't seem to get this to start up. Took apart the carb and everything with it seems to be fine. However noticed that the fuel/oil mix doesn't burn at all in the carb when trying to pedle start .. would this mean there's no ignition creating combustion to with the air/fuel mix in the carb.. ? Which means that my spark might be dead? Tried changing the spark plug but no luck. There is power though because the headlights will go on when pedling. Do these mopeds have a kill switch? There is a black switch hanging off the front handle bar that looks like one. Tried switching it the other way but still no luck.. However there is only 1 wire going into the switch and the other wires are taped together (not sure if they should be that way) ... Thinking there might be a ground wire touching another wire that's killing the spark? Person that it was baught from said it was up and running last time they tested it and the compression was good , but someone was fooling with the carb before he sold it. The carb looks like it was re-built with some newer parts. It's clean. Is it possible that the amount of air mix coming into the carb is set incorectly? .... The motor won't start up at all. Which leaves me to believe there might not be any spark , because if there was there would at least be some combustion , no?



Re: Can't get it started up! help!

prolly the fuel/air isn't burning because its 20 years old and has the consistency of goop?

Re: Can't get it started up! help!

it was running fine earlier

Do some basic trouble-shooting -

Start methodically -

Take out the sparkplug and see if it's wet with fuel. Smell it - it should smell just like the gasoline that's in the tank. If no - it's not getting fuel.

Put the sparkplug onto the wire but leave it out of the engine. Hold the side of it tightly againt the metal of the cylinder head while your friend kicks the bike over - if it sparks - it's not the ignition. If no spark - go look for it: back-track electrically until you find where the power to the igntion stops. That's you problem.

If there is spark - try a short blast of starting fluid into the carburetor intake. If it fires on ether - you have a fuel delivery problem.

That's how I would start 'fixing' it.



« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account