Weird Fuel problem on a kitted 89' Tomos Golden...

Ok, so I finally got my 70cc parma kit with a 70cc cylinder head on my 89' tomos golden bullet toptank. I also have one of those bent intakes and had to put two reedvalve stacked on each other so I could fit the carb on. But I took apart one of the reed valve and used its body as a spacer.

I got my carb on and everything and I also have a boost bottle connected to the intake.

Now the problem is when I turn on the fuel I see it flowing through the hose but then it starts spewing out from where the fuel line connect to the petcock. The fuel line is defiently not loose. But the gas comes out slowly. When ever I try to start it it won't. But when I took off the spark plug and put gas in the cylinder it starts up for a few seconds and dies. so this is obviously a fuel delivery problem.

I'm running with a 64 jet and the choke on my carb works perfectly.

Any help would be appreciated.

Thanks

Re: Weird Fuel problem on a kitted 89' Tomos Golde

check your petcock to make sure that the washer is still in place.

Re: Weird Fuel problem on a kitted 89' Tomos Golde

make sure your fload pin is in the carb under the float that was the same problem i hade with my lx after rebuilding the carb i forgot to put it in took me 3 days to figure out it was something as simple as that.

Re: Weird Fuel problem on a kitted 89' Tomos Golde

I'll double check. So did your gas keep spewing out slowly?

Thanks

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account