Not sure what the problem is

My 78 Garelli gulp matic 2speed it seems, is starting to have some problem. When the speedo hits 25mph it sounds like it's winding out. There's a higher pitch rattle, that sounds like it's turning to fast for it to keep up with itself. Now, less than usual will it catch and accelerate smoothly up to 30-32mph. Could this be as simple as tightening my chain? there's a little lag, other than that, I'm stumped. Any suggestions?

Re: Not sure what the problem is

Try looking at your clutch for starters. Kinda sounds like it's slipping.

Re: Not sure what the problem is

The clutch eh?

how could it be the clutch? it shifts just fine. The problem is that it winds out around 25-27.

Re: Not sure what the problem is

It'll shift just fine even if it slips.

Re: Not sure what the problem is

ya it does sound like the clucth

Re: Not sure what the problem is

Ben Van Zoest /

High end lag the top hole in the fuel riser tube maybe clogged

Re: Not sure what the problem is

My 1 speed will slip AT THE DRIVE GEAR. Garellis use a smooth metal friction based lock for the gears. If the wrong amount of torque is on the gear, your second speed gear might be slipping on the shaft. Look up the removal and installation directions on mopedriders.org for torque requirements. BTW, the NOI and VIP engines use the same clutch....

Re: Not sure what the problem is

Is the clutch something that has to be replaced, or can it be fixed?

Re: Not sure what the problem is

replaced, if it's worn out. It _could_ be out of adjustment, but prob'ly not. sorry

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account