MBK gets going...sputters..keeps going

So my MBK 50v gets going just fine....but then it starts sputtering...like it isn't getting enough gas..but there is plenty of gas in the tank and in the fuel line etc...This happens uphill, straightaway, downhill. Happened just now in a parking lot. Any thoughts?

--NB

Re: MBK gets going...sputters..keeps going

John Joedicke /

Clean the carb and check your jet for partial blockage. Put a filter on line.

Re: MBK gets going...sputters..keeps going

filter is there....carb is clean...jet is clean....

Re: MBK gets going...sputters..keeps going

do you have good gas flow from the tank? Does the air vent hole in your gas cap work? I've seen that cause this problem pretty often.

Re: MBK gets going...sputters..keeps going

hmmm how to check if air vent hole works?

Re: MBK gets going...sputters..keeps going

I see a hole on top of the tank cover, and on the inside....seems like nothing is blocking the air passage....there is gas in the fuel line...thoughts?

Re: MBK gets going...sputters..keeps going

moron me was .....wait for it....OUT OF GAS

Re: MBK gets going...sputters..keeps going

John Joedicke /

Might be a problem for a lot of people down there soon!

Re: MBK gets going...sputters..keeps going

Edward Helbling /

Nice work. I was going to suggest checking the plug......but I think your solution will work better.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account