Puch Maxi Starting Troubles

Yeah, as if we havent seen enough of these....

So my '79 Puch Maxi Sport MKII refuses to start, it sparks and gets to the point where it feels as if it is on the verge of cranking over

I cleaned the carb, i replaced the plug and i cleared hte fuel lines, but i have yet to flush the tank or get into the cylinder head

this morning i sprayed some gas into the cylinder head through the spark plug threading where it started up and humorously died in the middle of the street with on coming traffic....

any opinions or suggestions?

i think i still have some clogged jets in my carb and may not be delivering fuel to the engine...

thanks...

Re: Puch Maxi Starting Troubles

Maybe an exaust leak. Try feeling around the head while crankin' it. My '80 maxi just had the same problem. New gaskets and runs great.

Re: Puch Maxi Starting Troubles

There is only 1 jet in the carb

Unscrew the bowl and you will see it.... in the middle... its a timy brass screw with a hole in the center under the float...

Get a can of carb cleaner with a pipette attached and blast it out... you may need to run a fine strand of wire through it as well...

This should solve your problem.... if its the jet :)

Re: Puch Maxi Starting Troubles

well, it had been a gradual loss in power over the summer, you know where full throttle kills the engine and it immediately hit me as a carb problem...

it had gotten to the point where it did not start at all and when i tried to start it after cleaning it felt much cleaner and stronger...but not willing to pick up and go

the results from spraying fuel directly into the head were promising, it ran like a champ for 50ft so im reluctant to cite any compression/exhaust leaks...but ill see for an exhaust leak all the same because god damn, gas is 3.30/gal in Ct and i just need to get around hartford in the most awesome way possible...

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account