Need help on a puch thats been stored for a while

OK so i just got a puch maxi that has only 500 orig miles on it but it has been sitting in a garage for a long ass time. Is there a list of things i should do/check? the gas tank is rusted (im already on top of that) I cleaned out the carb and made sure that was all running. I tried 3 differnt spark plugs, the one that was in it, one from a motobecane and one from a garelli and i cant get it to start. It turns over just fine but the minute i let go of the decompression/clutch it dies. I would love to just go over everything i might need to do.

oh and on another side note, when i first tried to kick start it it kept making a horn noise no mattter if the horn was turned on or off. so i disconected the horn.

Re: Need help on a puch thats been stored for a wh

Try connecting the two horn leads you pulled out together. Now try and start it.

Re: Need help on a puch thats been stored for a wh

Regarding the horn circuit.... I had a friend with the identical Puch and problem… and it happenned after it sat for awhile..

Those switches stick on so someone disconnected the horn and with the horn circuit open the ped wouldn't start!

I sprayed some WD40 right into the switch top and bottom and worked it till it freed itself up... reconnected the horn... and the ped fired right up….. that may work.. or there may be a short-circuit in the horn itself.. on that model if the horn wires are disconnected the ped will not start but I’ll bet it’s in the switch… his stuck on too!

Either way connect the horn wires together and wrap some tape around the connection to complete the circuit..

Hope this helps..

Re: Need help on a puch thats been stored for a wh

woooot it worked thatnks dude. it actually fired up and i rode it for 15 seconds efore it died. PROGRESS!!!

I am going to by that cream gas tank kit (coke and rocks didnt work well enough) and go from there. Are there any other things i should do or try that are like standard procedure for old bikes?

Re: Need help on a puch thats been stored for a wh

Jason Luther /

change the trans fluid. type f transmision fluid. the correct sparkplug is an NGK B5HS. sounds like you are doing just fine :) why did it die after 15 minutes? did it run out of gas? did the carb flood over? check that fuel is flowing to the carb nicely.

Re: Need help on a puch thats been stored for a wh

ok got my 81 puch about 12 weeks ago . i used por-15 kit for my gas tank worked great. check hose swivel connector on carb there is a very small screen in there . i bet it is rusted .

Re: Need help on a puch thats been stored for a wh

forgot about horn had same trouble with mine my puch horn switch has to be closed for the horn to be off and open to make horn work.funny wiring? unscrew switch and open up and spray some cleaner on copper . put switch back together. worked for me. p.s 70cc speed kit with amal car doing 40mph puch is 2 speed.

Re: Need help on a puch thats been stored for a wh

ok now its running fully but the acceleration is real slow. if i give it too much gas it doesnt accelerate, i have to give it hafl gas and slowly move my way up to full throttle.......

Re: Need help on a puch thats been stored for a wh

oh and PS I gota NGK B5hs and it doesnt fit into the spark plug holder. it needs one with an end that looks like screw threading, the one I bought looks like a petcock on a gas tank

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account