2003 Kinetic TFR USA not running worth sh******

Hello,

I have a 2003 Kinetic I got new 1.2 years ago. It was not running to badly until I had to replace the rear rim with a new do to lose of many spokes in a short time. I have cleaned carb well. It has a #30 pilot jet & a #48 main jet. It has 4755 miles. I am running 40:1 fuel. Fuel filter has been replaced and the banjo screen is clean. The spark is good also. There is good spark and fuel flow to the bowl. The float is in good shape and freely moving. The carb was a little lose on the intake tube but that is taken care of.

The original problem was that it did not get top speed it dropped 8 MPH off top (30-34 MPH). Then it drop 7 more. Then drop to 12.5 MPH and finally 8 MPH. During this drop it stopped also climbing hills. I have a lot of hills around here. some times it would only go up them at 10 MPH with help pedaling, but that is better than pushing for the 1/2 mile to 1 mile hill. I was able to get it back to 20 MPH top speed but only after free running it with 10 PSI air into air intake. It now will almost not start and only run at sort of idle with full/partial throttle. I have tried adjusting the low speed idle screw ( no damage) and does not matter where it is set. I have also tried the mixture screw (no damage) and still changes. It will run with both screws closed down.

Re: 2003 Kinetic TFR USA not running worth sh*****

Could be two things;

You need a new belt

and/or you need to decarbonize your muffler and exhaust port.

Try running it for a short test drive without the muffler and see if performance improves.

Maint schedule calls for decarbonizing the muffler at 3000 miles. You have 4755 miles on you bike, quiet a bit past the recommended maintenance.

Re: 2003 Kinetic TFR USA not running worth sh*****

Belt is in good shape and tension seems about right.

The effect is the same with or without the muffler except about 3 to 4 MPH slower without muffler.

Re: 2003 Kinetic TFR USA not running worth sh*****

maby the head and piston need to have the carbon removed. also check the exhaust port for carbon. if thats never been done to your moped im shure it needs it. just my 2 cents worth. for what its worth. doug in tx.

Re: 2003 Kinetic TFR USA not running worth sh*****

Thats true,but I put 3217 miles on an '03 TFR,and it still ran fine.Also,the belt looked fine.I never had any problems with the spokes,and it still had the original tires on it,and the original plug in it.

Re: 2003 Kinetic TFR USA not running worth sh*****

Check your compression.Should be around 120.

Re: 2003 Kinetic TFR USA not running worth sh*****

Compression is averaged at 133.

Re: 2003 Kinetic TFR USA not running worth sh*****

There is some carbon but not much and I the original and performance muffler ( only 200 miles on this one) and this same results.

Re: 2003 Kinetic TFR USA not running worth sh*****

is there any more hlep on this???

Re: 2003 Kinetic TFR USA not running worth sh*****

Steamboat Aka J. R. Stevens /

Because your problem is across all speeds, it sounds like a clogged exhaust which you have checked so take a short run without your air box, also check your timing. Jim.

Re: 2003 Kinetic TFR USA not running worth sh*****

Allen Murphy /

Check your fuel filter--might be clogged, or got water in it, making the element swell.

Easy test, easy fix, and CHEAP too!

Al Murphy

Re: 2003 Kinetic TFR USA not running worth sh*****

This one has a CID not points. So where would I check for timing?

Re: 2003 Kinetic TFR USA not running worth sh*****

Fuel filter has been replaced. and ran without exhast on. Still same thing.

Re: 2003 Kinetic TFR USA not running worth sh*****

it could be because its a kinetic

Re: 2003 Kinetic TFR USA not running worth sh*****

i think your problem is that you have a USA made moped lol. 1979 Sachs Prima (german). Starts with a quarter turn of the peddle, 30-35 mph. though slightly sluggish off the line.

Re: 2003 Kinetic TFR USA not running worth sh*****

Allen Murphy /

Yuck Fou. :-)

Al Murphy

Re: 2003 Kinetic TFR USA not running worth sh*****

what exactly is this..."kinetic" you speak of?

Re: 2003 Kinetic TFR USA not running worth sh*****

Craig,

Have you been able to resolve the problem?

Have we spoken about this already? If not shoot me an email (Bzollo@cosmotor.com) and I will see what I can do for you, it will take a little time. Be prepared I may ask to have you send that motor to me.

P.S. the TFR USA in manufactured in India, Pune to be exact. ;)

Re: 2003 Kinetic TFR USA not running worth sh*****

blahhhhhhhh :-D

Re: 2003 Kinetic TFR USA not running worth sh*****

ಠ_ಠ Jon Folks ಠ_ಠ /

Did you clean the main carb jet? Hows your clutch doing? Might need new clutch plates?

Re: 2003 Kinetic TFR USA not running worth sh*****

Main jet is sqeeky clean, I can see the same amount of daylight through it as when I originally put it in 3600 miles ago.

As for the clutch, it still seems to be doing its job as before. The engine is not revving right with load or at present at all.

---Craig

Re: 2003 Kinetic TFR USA not running worth sh*****

The only thing left to check is the Air filter :P

Re: 2003 Kinetic TFR USA not running worth sh*****

Craig and I have been round and round with this Ped, we both just keep scratching our heads on it, pretty much everything's been replaced or cleaned. Craig I replied to your email check it out please...

Re: 2003 Kinetic TFR USA not running worth sh*****

There is nothing in the airfilter at all I could through an ant through it and only the many bends that the air goes there would the ant hit.

Re: 2003 Kinetic TFR USA not running worth sh*****

Mike O\\\'Brien /

I am having the same problem. Just started one day and steadily lost power. How should my mixture adjustment be set on bottom of carb? Turns?

Mike

Re: 2003 Kinetic TFR USA not running worth sh*****

Your main bearings might be shot.

The resistance would be too much for your little motor

to overcome.

Something to check anyway.

Spence

Re: 2003 Kinetic TFR USA not running worth sh*****

Your guess is good as mine, since I have tried every 1/8 of a turn from FULLY CLOSED to FALLING OUT. No change in results.

Re: 2003 Kinetic TFR USA not running worth sh*****

If it was main bearings, then why would it start after a rear wheel change and I mean change rear wheel and start bike and problem is there. And also with a little extra air added at one time actually get things back close to original running conditions. A bearing problem usually is a progressive thing, and makes lots of noise.

2003 Kinetic TFR USA not running worth sh******

Steamboat Aka J. R. Stevens /

https://www.mopedarmy.com/forums/discuss/read.php?f=6&i=15821&t=15821 Check here for suggested carb adjustments. Jim

Re: 2003 Kinetic TFR USA not running worth sh*****

Metallurgy is important, and Chineese scooter makers don't put in the effort on that. A perfectly engineered engine isn't worth SH*T if it melts!

an $800 scooter will probably eventually cost you $1200 worth of being a pain in the arse.

Where as a $1500-2000 scooter (provided it's not a lemon) will run forever with proper care/maintenance.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account