Bad noises

My ped has a strange rattling noise coming from the cylinder at least thats where im pretty sure its coming from like a pinging or rattling of metal it sounds like a piston ring may be loose, maybe? anyway i think it may be connected with my moped not going. i can get it started by pedaling real fast on the stand and if i keep it at half throttle it will keep going but any lower it stops all the while making scary noises. i have adjusted the idle but it had no effect any help wopuld be greatly appreciated i am waiting for it too cool off (Engine and enviornment phoenix sucks) then i am going to take my head and stuff off to check piston rings. thank a ton for any help

Skreee!

Re: Bad noises

Elric Wizardsboon /

i just took it around the block and the noise goes in and out but my moped goes only about 15 mph at full throttle im not sure whats going on.

Thanks

Skree!

Re: Bad noises

See Ya Moped Army /

You may have busted a ring.

Re: Bad noises

Elric Wizardsboon /

just took it all apart and my piston rings are in tact and seemed to be on fine and i was glad to see there was no scoring in the cylinder or the piston i am stumped any ideas anyone?

Re: Bad noises

metalic sound.. runs crappy.. check the flywheel..

check everything.. and dont ride it again.. you might close to destroying something.

Re: Bad noises

How much side to side play does the connecting rod and pison have?

Grey

Live to ride, Ride to work

Re: Bad noises

Elric Wizardsboon /

from one side to the other i would say that the rod and piston has about a 1/4 inch of play give or take 1/8 of an inch. i checked the flywheel and it seems to be fine. :^ (

Re: Bad noises

Jason Luther /

1/8 to 3/8? are you sure? if so, youve found your problem.

Re: Bad noises

Elric Wizardsboon /

i put all the stuff back on and i got rid of the noise but preformance still is crappy this could be because of the side to side movement? how do i go about fixing that?

Skree!

Re: Bad noises

It depends on what you're measuring..

If you're just pushing the piston from side to side it will normally move quite a bit. But clearance down at the big end of the connecting rod should be close to about half a millimeter (0.02 inch) and that's what's important..

Use a feeler gauge to measure that distance (big-end rod bearing side clearance).

If the noise disappeared after reassembly, maybe the engine / exhaust and stuff just needs a good going over.. tighten all bolts to the proper torque.. look around for things that may have come loose.

Re: Bad noises

I had a really nasty clattering noise coming from the engine on my Moby..Sounded like a bad piston, or broken rings. I pulled the exhaust pipe to get a look at the cylinder, and what I could see all looked ship-shape. Piston, rings and cylinder wall all like brand new.

So I did some investigating, and it turned out that the noise was coming from a small piece of hard carbon loose in the exhaust pipe. it was half the size of a penny, but it made a huge racket inside that hollow pipe. Cleaned the pipe, and it was much quieter after that.

It's making a little noise, again. I assume some more hard carbon has broken off, after being disturbed by the cleaning operation - which was not very thorough.

Re: Bad noises

Elric Wizardsboon /

My preformance is still crap though anyone know what it could be ? i took off the silencer at the end of the stupidly long pipe and it ran the same.

Re: Bad noises

Elric Wizardsboon /

I have noticed that some other people have had the running real slow at full throttle problem and they said their problem was their jetting could i have screwed something up when i cleaned the carb?

Re: Bad noises

Most tomos moped do have that "ping", it's not uncommon. does the bike smoke alot when it runs?

Re: Bad noises

What kind of bike is it?

Re: Bad noises

Elric Wizardsboon /

its a 1984 derbi c-5 diablo it used to do well over 35 not sure exactly because speedo was inaccurate but now it doesnt go past 15.

Skree!

Re: Bad noises

I have a 79 Derbi Variant. It makes a metallic scraping noise when it idles. Some people I talked to said it was the "running clutch" or "clutch shoe". Something to do with the variable transmission. Mine too runs slowly about 20 mph tops whereas it used to go 35-40 mph. I live Lawrence KS and it seems that there are very few people in this area who know anything about mopeds and those who run "moped shops" have never heard of Derbi and they only sell those crappy little scooters. If you find out what is up with your ped please share with us.

Re: Bad noises

Lawrence, KS, eh? Some of us are maybe going to meet there and ride this weekend if we can pull it off. There are a few of us on here from the area. I'm from Shawnee, 50+ is from Topeka and Flammenwurfer is from Topeka too. Rick is somewhere from around here too. Those are about the only Kansas-ites that I know of.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account