Tomos A3,A5, A35??

Michael Colin /

I have a 1993 A5 Sprint M. If I need a new piston let say. Do I get the one for a3 or a35. I haven't seen a bood on A5's, but from what I see is the only difference between the three different engines is what the cylinder looks like. I'm I write or wrong? Also what spark plug should I use for my A5? I have no reference for that engine. Thanks SCV-MIKE

Re: Tomos A3,A5, A35??

Don Pflueger /

depends on what engine you have. in 93, you may have had the a3n or the a35. look at it and compare cylinder heads. they are vastly different.

Re: Tomos A3,A5, A35??

John Joedicke /

Well if says A 5 on the jug then it is a A35 engine. Original piston is 38mm which is 49.5 cc's Use a Champion L86C.

Re: Tomos A3,A5, A35??

Michael Colin /

Hi This is from mopedunkyard

PART# DESCRIPTION PRICE

TM-001 (1) Tomos A35 (reed valve) piston kit

-std. 38.00 mm bore-includes piston,

rings,12mm pin, and clips $42.95

TM-002 (1) Tomos A35 (reed valve)piston kit

-1st OS 38.50 mm bore-includes piston,

rings,12mm pin, and clips $42.95 (special order)

TM-003 (2) Tomos A3 piston kit

- std.38.00 mm bore-includes piston,

rings,10mm pin, and clips $42.95

TM-005 (2) Tomos A3 w/A35 transmision piston kit (92/93 sprint only)-std. 38.00 mm bore-includes piston, rings,12mm pin, and clips $42.95

PR-022 (1a) Piston rings-A35

38.00/FG/1.5 $5.95ea

PR-021 (2a) Piston rings-A3

38.00/FG/2.0 $5.95ea

Now I have a a5 1993 M -sprint. do you think mine is TM-005 as stated above?? Thanks MIKE

Re: Tomos A3,A5, A35??

John Joedicke /

I would say you need to pull it down and look at what you have. No sense buying the wrong stuff as your pin may be a 10 or 12 and the rings 1.5 or 2 mm. Your taking it apart anyway so jump to it. Also you may be scored up in the jug.

Re: Tomos A3,A5, A35??

Don Pflueger /

i would call ike. mopedjunkyard is usually over priced. look his number up on his site www.ikesbikes.com

New Problem

Michael Colin /

I cleaned the exhaust, and the spark plug. It had a champion L76 and I changed it to L86 as instructed. My ped is much faster and it starts easier. Now the new problem. I just got bulbs for the tail light. The brake light was always on do to I didn't have them connected to the hand levers. The other light bulb has been burnt out. Now that I replaced the burnt bulb they are both on when the head light is off and you can barely see them, but when I turn the head light on they both go off. I didn't touch no wires so what do you all think happened? I put the burnt bulb back in where it was to have things back the way I had it and it didn't go back to working as it did before. MIKE

Re: New Problem

Don Pflueger /

you need to plug the wires in at the levers and check the ground at the tail light.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account