Only running with choke on

I just put a 70cc airsal kit on my 95 lx. It starts almost perfectly but stalls as soon as i turn the choke off. its runnin a 58 jet and a bullet exhaust. I also put an offset manifold on it to get to the carb easier.

Does anyone have any ideas?

thanks

Re: Only running with choke on

I had this problem when it still had the 50cc cylinder and it started after i put a clean fuel filter in it.

Re: Only running with choke on

Try reinstalling the original intake manifold and air box and filter element and just get the engine running..

Modifications can easily go wrong somewhere down the line and leave you guessing about wtf happened and what's causing the problem.

But if you start with an engine that runs great and change one thing (then test run), change something else (test again), if something goes bad you know what caused it.. the cause was the last thing you did.

So, i recommend you start over and take it one step at a time and test..

Re: Only running with choke on

i put the 53 jet back in and it runs perfectly. im hittin around 50

Re: Only running with choke on

watch out.. cops all over the place on saturday night..

Re: Only running with choke on

Don Pflueger /

you have an air leak and need to upjet to maybe 64.

Re: Only running with choke on

Don Pflueger /

you had this problem BEFORE installing the airsal kit?

if so, you need to look at the fuel system starting with the gas cap vent and work your way down. something is plugged up somewhere between the vent and your carb.

Re: Only running with choke on

Don Pflueger /

your too lean.

Re: Only running with choke on

John Joedicke /

Air leak at the intake manifold will screw up your running /idle. It will just die on you, check all gaskets and clamps and torque your head down to 10 lbs

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account