dellorto carb problem

i have a 78 garelli gransport, which i have been trying to get to idle properly. when i adjust what i would call the "idle screw" on the side of the carb so that it idles properly it will ride fine and idle fine, but after riding for a short time it will stall and not start untill i loosen the screw enough that it does not idle then it rides fine, no more stalls but no idle. hope i described the problem clearly enough thanks

Re: dellorto carb problem

does your ped have a choke? this happens to me also on my hero-majestic. i think it could be vacume leaks from the carb, or the choke plunger seal on the bottom. check my post.

Re: dellorto carb problem

well, your fuel float is not opening when it's supposed to...clean your carb real good. When a ped starves for fues, it runs lean and thus idles fast. make sure the fuel float is working properly.

Re: dellorto carb problem

what is the best way to clean the carb. some one told me to blow out the jets with a compressor also how do i tell if the float is working properly (i just replaced the float needle about a month ago idled fine after that untill i had a carb. clog after i uncloged the main jet is when this problem started) also the choke is just a small swithch on the carb itself no gasket that i can see also has a new seal on the bubble that contains the foat and a new "idel screw" the spring on the Idle screw is in bad shape does that spring serve any important perpose or can i remove it or should i replace it. sorry i don't know the correct names of the parts i have tryed to be as descriptive as possible thank you for your patience, ben

Re: dellorto carb problem

well, i figured out the problem. my spark plug is getting what i would describe as a layer of carbon and maybe a little oil causing it to not work. is my mix off? should i be using one of those all in one mixture packs? also what is the best way to cleam out my exhaust.

Re: dellorto carb problem

Jason Luther /

too much oil in the gas is usually not a problem unless you have _way_ too much. sounds like your carb needs to be cleaned. try getting a brand new spark plug too. is the air filter real dirty? its probably something simple. your idle should only be adjusted and set when the engine is warm, all peds will idle fast until the engine warms up, thats when you should set the idle.-jason

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account