moped engine problems

my moped engine starts fine and runs great on my kickstand

when it take it off or try to start it off it acts as if it had no power

when it is on the stand it screems but off it dies

any suggestions on how to fix this or what the problem actually is??

thanks

kev

Re: moped engine problems

It would be nice to know the make and model of your 'ped.

Is this a new problem? Was it running fine before?

Sounds like fuel starvation to me. It runs good when lightly loaded but when the engine is loaded it won't pull.

Clean the carb as a start.

Re: moped engine problems

Yes, could be any number of things. Poor compression, marginal spark, leaky crank seals or carburetion, as was already mentioned.

Re: moped engine problems

Kevin B. /
kev OP

i dont know what kind of engine it is that is another problem!\

it came off a general moped and it is not a minarelli or sachs 505!

seals are all new

good spark and plug

good clean carb

i dont know what it is!!!

thanks for the help

kev

Re: moped engine problems

take some pictures of it, and post them, maybe one of us could id the bugger

Re: moped engine problems

Kevin B. /
kev OP

i will do that tomorrow if i get a chance

thanks for the help

kev

Re: moped engine problems

Michael Vogt /

It could be the points make sure that they are clean and gaped right (had the same problem on my moped)

Re: moped engine problems

Jeff Strahle /

how did you change the seals if you don't know what kind of engine it is?

Re: moped engine problems

Kevin B. /
kev OP

previous owner changed them

they are all fine

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account