79 Puch Maxi

Patrick Menefee /

I'm having some trouble getting it running. I redid the engine, putting on a 70CC kit and a high compression head, I bought a new crankshaft and had to grind down the crank case to get it to fit without rubbing, but now it moves fine and doesnt rub. I bought a new petcock and exhaust, put all those parts on there and tried to run it. The gas tank had some junk in it, so I flushed it out and flushed out all my gas lines and my carb too. Today I tried to get it started and it wouldn't go though. I had gas running through the lines, and i started it a couple times but it wouldnt run fast at all, and then it would bog down and die. Does anyone have any suggestions on whats wrong? Thanks

Re: 79 Puch Maxi

SOUNDS LIKE A FUEL PROBLEM, YOU SAID YOU FLUSHED OUT CARB, DID YOU TAKE APART AND CLEAN, MAYBE NEEDS NEEDLE IN RICHER POSITION OR LARGER JET, HOPE THIS HELPS, JUST MY OPINION, MOTOBREEZE

Re: 79 Puch Maxi

Louie Armstrong /

Did you seal the tank?

Re: 79 Puch Maxi

I have the same problem on my 1980 Puch Maxi. There is a thread from yesterday on the general discussion board about it (Bogging Down...). Anyway, I was given the ped a couple of weeks ago - it was in pretty sad shape. But, I cleaned the gas tank with soapy hot water and some nuts (20 to be exact - you want to count them so you know when you get them all out) and with Kreem A & B (didn't seal it). Got a new petcock, filter & hose. Cleaned the carb. The ped started and runs smoothly when idling and goes a little but has no power. I took the carb off again last night and cleaned it again but didn't have time to get it back on. Hopefully that is the answer to my problem ... and yours!

BTW, the carb's float operates a tiny valve that I think was sticking/leaking. You can get at that by pushing the pin out of the float's hinge. I didn't know that the first time around. I also didn't know that you could get the main jet seat out either until yesterday. You probably already know that though. GLTY

Re: 79 Puch Maxi

Louie Armstrong /

Did you guys check your timing?

A rich fuel mixture can also cause bogging.

Re: 79 Puch Maxi

sounds like an airbox/jet mismatch... did you take the plug outta the airbox when you upjetted?

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account