Tomos engine problems

I just bought a targa last week and finally had it running today. The only problem is it only starts with the choke on, it will not start without it. Also the choke wont turn off unless I take the air filter off and manually turn it off. Any help would be appricated

thanks

travis

Re: Tomos engine problems

The reason for your choke not turning off may be because your throttle cable isn't tight enough. Underneith your throttle there is a little screw, unscrew it, then pull some more cable through and rescrew it in ..

Re: Tomos engine problems

my choke won't turn off unless i give it full throttle and then pull up on the lever...try this.

Re: Tomos engine problems

When the engine is cold it will only start when the choke is on, that's normal. Run it with the choke on for 10 seconds then give it full throttle, the choke should click off. Warm it up a few minutes b4 you ride. If the choke doesn't come off, follow the instructions given earlier on the thread. If the engine only runs with the choke on you've got a clogged main jet.

Re: Tomos engine problems

Dirty carb or fuel restriction is usually the cause of needing the choke to pull enough fuel. I'd go thru the carb,cleaning the jet,emulsion tube holes and any passages immaculately.

But it might not be necessary if you find you have a dirty petcock screen or banjo filter. don-ohio

Re: Tomos engine problems

Hey guys this is my first moped and I really appreciate the help with this problem. Everything is fixed and hopefully when the rain clears I'll be able to ride this weekend.

Thanks!!

Travis

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account