problems tomos a3

is it me or dose tomos speedometers stink....i think mines a bit un accurate to say in the least...any way to fix this?

also my bike takes off fast...but when it gets to about 12-15 mph it wont shift into second gear easy....if im going downhill the bike will shift very easy into second gear but if im on even the slightest incline my ped has hell getting out of first gear...but sometimes it dont have as much trouble as other times...the motor is wound out also when im on a slight inline, holding at 12-15mph with plenty of power to pull into second gear..just wont shift...this tranny has a little over 3000 miles on it..its my guess its just the clutch, but i thought i should ask anyway.

also, how much ike charge for a clutch?

thx for the help,

mike c

Re: problems tomos a3

Don Pflueger /

none of the tomos speedos are accurate.

i would check you tranny fluid level.

Re: problems tomos a3

well i filled my tranny till it ran out the hole in the side...plugged the hole and went...ill see if i cant find the correct amount in the manual...but thats seems easy enough...thanks again.

thx,

mike c

Re: problems tomos a3

Don Pflueger /

thats all you need to do. its about 10 ounces.

Re: problems tomos a3

Jeff Strahle /

yes it is exactly 10 oz. for tomos a-3's

Re: problems tomos a3

great. thanks again.

mike c

Re: problems tomos a3

Let all the fluid run out that hole in the side. In other words, the fluid level should be level with the bottom of the hole. I noticed this with my Tomos A-3 too. They shift a little slow, its just a Tomos thing. My buddy Jarret's Puch 2 speed shifts much nicer. Too bad its a Puch: I still beat him.

Re: problems tomos a3

thx for the help guys.

mike c

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account