Puch Newport Spark

I just finished installing my new Athena 70cc kit. I put it all back together and now I'm not getting a spark. My points look fine, my taillight bulbs look brand new, and I _believe_ the wires are all connected in the right slots. This is how I've done it:

Blue/Green > Blue Green + Blue Green

Blue/Black > Blue/Black + Blue

Navy + Black > Black

Brown > Green/Black

Yellow > Yellow

Green + Green > Green

Grey > Grey

Is that correct for a 78 Newport?

What else can I check?

Re: Puch Newport Spark

See Ya Moped Army /

*wires in the left column are from magneto.

Blue/black > Blue/Black

Blue>Blue (to coil) + Black (to ignition switch)

Green/black >brown

yellow> yellow

green> green + green

blue/green > blue/green + blue/green

grey>grey

Re: Puch Newport Spark

Hey thanks man, you're a lifesaver. I have one question though...

After reorganizing all the wires, I have 2 black wires on the right side. Where does which go?

Re: Puch Newport Spark

See Ya Moped Army /

Where do those black wires originate from? I only know of the one black wire from the ignition switch. Are there turn signals on this bike?

Re: Puch Newport Spark

I can't tell exactly where they originate from - they go up the body towards the handlebars. I do not have turn signals - just Horn/light + Engine Stop.

Re: Puch Newport Spark

See Ya Moped Army /

I have no idea what they are unless someone patched some black wires in the harness somewhere. The only black wire should be coming from the on/off switch.

Re: Puch Newport Spark

Okay well I plugged one of them in there and it sparks great now. - though it's not starting!

Everythings connected, it's getting gas, spark, compression, brand new carb(fresh out of the package - so it's clean as can be). What do I check next?

Re: Puch Newport Spark

See Ya Moped Army /

I would check the compression with a compression gauge. If you've got a nice, strong blue spark and fuel to the carb, there's not too much else that would prevent it from starting other than weak compression. Try spraying some starter fluid or carb cleaner into the intake and see if it starts up.

Re: Puch Newport Spark

Okay, I'll have to go buy a compression gauge. You mean just spray carb cleaner into the hole the airbox attaches to?

Re: Puch Newport Spark

See Ya Moped Army /

Yes, or you could spray some directly into the spark plug hole and then replace the plug and crank her over. If it's go a decent spark and compression, it should fire right up.

Re: Puch Newport Spark

I went down to start it again before spraying anything and it started right up. : : shrug : :

I rode it around for about 30 min - looks fine.

The other black wire - my On/Off switch has 2 off positions. It has a black wire for each position. tadaa.

Re: Puch Newport Spark

See Ya Moped Army /

Glad to hear you got it running again.

Re: Puch Newport Spark

Thanks again for your help.

Beamer

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account