Puch Runs for 10 min then starts to die

I have a 1979 puch that i recently put a new top end on and it runs good. But after maybee 10 mins of running it will start to bog down, become weak and run rough. I can keep it running somewhat and when it stalls i can usually get it to start back up but it still runs rough. If it sits for a while like overnight its fine agian and will run great for a little while until it does this again. I am thinking the problem is either fuel related or seizing up. I have a 58 jet in it and i tried a 62 but that just made it 4 stroke the whole time. Any suggestions, Thanks

Mike

Re: Puch Runs for 10 min then starts to die

you mean it craps out after 10 minutes of top speed or normal stop-and-go driving?

It would help if you can provide specific details of how you might force the situation to happen...

there's dozens of potential reasons if it's overheating.. narrow them down to a few.

Re: Puch Runs for 10 min then starts to die

Ben Van Zoest /

Take off the magneto cover, ride until it stalls and try to rotate the magnet drum manually if you can't turn I would say the piston seized. Did you do proper head bolt tightening?

Re: Puch Runs for 10 min then starts to die

Jason Luther /

what if the fuel isnt filling the carb bowl fast enough? but yeah, some more info would be nice.-jason

Re: Puch Runs for 10 min then starts to die

ಠ_ಠ Jon Folks ಠ_ಠ /

a bad condensor tends to cause this.

Re: Puch Runs for 10 min then starts to die

I would also check the gas cap vent. When it runs and stalls after awhile it is usually not getting gas. The gas is gravity feed. If the vent is blocked the gas can't flow fast enough so the carb becomes empty. Sitting overnight it has a chance for the dribbling of gas to fill it back up. Pull the hose off and see if its flowing good with the cap on and off. If the flow is bad, take the cap off. If it's better, the vent is clogged, if not check the petcock for a obstruction and cleaning.

Re: Puch Runs for 10 min then starts to die

hey

as a last resort it may be leaking crank seals.

this would make your engine run rough after a short period of time after it gets warm.

they*re kinda hard to get to

Re: Puch Runs for 10 min then starts to die

Cole Todorovich /

my garelli had this same problum when i got it and i had soaked the carb in carb cleaner and taken it abart twice but i did a third time and went through ever hole in it with a small wire and then it worked just fine so i guess i wasen't very good at carb cleaning till the third time around.

bloodyfinger

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account