Moped wont idle ive tried everything

My 1979 puch maxi just wont idle. Ive tried everything and entirely rebuilt the carb. It runs perfect at higher rpms, but at idle it seem like it just cant get any gasa or air. Like it doesnt even have enough power at idle to accelerate from stop. Any suggestions? I need some ideas. I think ive tried almost everything possible.

Thanks mike

Re: Moped wont idle ive tried everything

Don Pflueger /

make sure the head bolts are torqued to 10 ft/lbs and the base gasket is not leaking. and replace the magneto side crank seal.

Re: Moped wont idle ive tried everything

If you have cleaned the carb, try adjusting the timing there are posts and articles on this just do a search. Pull and push your cables around and make shure there is no kink tighten or losen the cable adjuster on the carb top. It might be your petcock (the on of valve) when the fuel line is detached gas should pour or stream out, if it trickles or drips then you have a problem there.

hope this helpes, Puchs are the best mopeds keep at it you will get it.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account