tomos rattle starts at 35

Hello forum members.

I have searched for an answer for this question but haven't found any help. Perhaps you have experienced this problem.

My '04 Tomos with BiTurbo and 600 miles starts and runs great. However, when I go over 30 and approach 35, a loud rattle starts to occur. When I back off the throttle, it disappears. The sound seems to be coming from the speedometer or front wheel area rather than from the engine. It sounds like a rapid clicking rattle that is louder than the engine. When I slow down, the noise stops completely.

Does anyone have any idea what might be causing this and how I might fix it?

Thanks for your time.

Re: tomos rattle starts at 35

well. I hate to say it but sounds like transmission. the only time I ever heard clicking was in a tranny that was little messed up.

other then that I can't help you.

Re: tomos rattle starts at 35

Don Pflueger /

your plasticshrouds are vibrating.

Re: tomos rattle starts at 35

Jason Luther /

my front wheel bearing came loose just a tiny bit and my speedo sending unit? on the front wheel was banging back and forth at high speed-jason

Re: tomos rattle starts at 35

Sounds like the plastic covers to me too. Been there, done that.

Re: tomos rattle starts at 35

I don't think so...my Tomos has no plastics and it does the same thing. Its been rattling off/on for a year now.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account