79 hobbit carb problems ?

I am having all sort of trouble with my sons moped, As far as keeping it running. I have taken the motor off to get to the carb and cleaned it and put it all back together. It took right off running for about 5 minutes then it died again. It will idle all day long, but once I give it some gas it bogs out. If I let off the gas, it is fine. Go figure. If anybody can give me an idea, that would be GREAT!!! I have a listing looking for a carb right now, if someone has one let me know.

Thanks

Rick

Re: 79 hobbit carb problems ?

A common mistake when working on these carbs is to reassemble them incorrectly. The float bowl should go on with the drain to the right side. Check this first.

Re: 79 hobbit carb problems ?

I was wondering if there was a difference because it goes on both ways. Thanks for the advice.

Rick

Re: 79 hobbit carb problems ?

There's always Fred's Guide if that doesn't work.l

Re: 79 hobbit carb problems ?

isn't it a pain to remove the whole frame to get to the carb

Re: 79 hobbit carb problems ?

If it is difficult, you are doing it the hard way...there is a very easy way. I should know, I have done it many times!

Re: 79 hobbit carb problems ?

i just removed 2 cables and 3 bolts to get to the carb

Re: 79 hobbit carb problems ?

I took off 3 bolts, decomp cable and unhooked the wires running from the motor. but when you do this the frame wants to flex when taking it off and putting it back on. I put zip ties on the frame to keep it from flexing.

Re: 79 hobbit carb problems ?

Well tell me what is it.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account