help , 70cc kit won't work right

SO I bought this moped, the guy told me It has a 70cc kit on it, but it runs slow as hell. 20mph max..

so I cleaned the carb, changed the filter, flushed all fluids and put fresh stuff in. I ran it without the muffler and air filter and it seemed to have quite a bit more pick up, so I guess thats my problem, but I don’t know what kind of exhaust I should buy for it. Should it be something to match the kit,,,,?

I need some sppeed for these san francisan hills

help please, thanks.

Re: help , 70cc kit won't work right

what brand kit?????

what brand moped???????

we can't help you without more info!!!!!!!!!

Re: help , 70cc kit won't work right

Don Pflueger /

THATS WHAT I ASKED HIM TO IN THE GENERAL DISCUSSION.

Re: help , 70cc kit won't work right

Matthew Westberg /

Yeah but he's more likely to get a good reply in the repair forum. Probably.

Re: help , 70cc kit won't work right

Don Pflueger /

probably. but i read the general discussuion first so i answered there first.

Re: help , 70cc kit won't work right

Alright guys, stop bashing me,

I am not sure of the kit , but I do know it does have one, by the looks of things, I have taken this engine apart twice now , so the parts seem to be there to show it is kitted. it is a Sachs 505/1b engine, with a 25/40 exhaust, The timing is the only thing I haven't checked cause I don;t know how, thanks anyway for the replys,,,,,

Re: help , 70cc kit won't work right

Steve Murphy /

I have a feeling you might not have a kit. The 505 1B is the "low power" 20mph engine, so it sounds like it's running right for stock.

The attached picture shows the stock cylinder head and piston next to an Autisa kit. If you can't measure your piston, check the configuration of the fins on the head, kits have more/different fins than stock.

1096373915_sachskit.jpg

Re: help , 70cc kit won't work right

hey thanks for the pict steve, well mine looks like the one on the right, the kit, one, just like it in fact, and I even looked at that kit on the mopedwarehouse and saw all the parts, I got em all, I just haven't looked at my piston yet.

I took the exhaust off and air filter and it ran faster, so maybe those are my problem, Do you need a special air filter for a kit, or will the stock one work, I just ordered a new one so I will see if that will do any good, thanks,,,

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account