moped wont stay running hard problem

i got a 1980 puich maxi with the 70 cc airsal kit. i had it idling and the chain popped and after that it wouldnt start. so after many hours it finally started with the help of starter fluid. i was riding it for about 5 minutes and it cut off and wont start. its got very high compression and fuel flow and spark. my best guess is the magneto is about shot. i wanted to know if anybody knew any other possible causes of my problem before i bought a new magneto.

Re: moped wont stay running hard problem

Mmmm... did you install the piston upside down? Check and make sure the wristpin, clips and rings are ok... you need to crack that baby open and make sure you didnt dammage something inside the engine.

Re: moped wont stay running hard problem

Don Pflueger /

if you had a magneto problem, you would either have spark,or no spark. my best guess is 20+ year old engine, new top end, lots more compression, OLD CRANKSEAL. replace the magneto side crank seal.

Re: moped wont stay running hard problem

Good call don... I would listen to don bobby, he knows as much as anyone around here.

Re: moped wont stay running hard problem

Bobby Smith /

i tore the whole motor apart piece by piece. where is the crank seal. my ride was fine untill the piston got scored real bad so i ordered a new piston and installed and thats where the problems come from.

Re: moped wont stay running hard problem

Don Pflueger /

crank seals are located in thecase where the crank shaft comes out. it is the black rubber seal. crank seals maintain crank case pressureand vacuum.

it is possible that your piston is in upside down too. when you pulled thecylinder off, did you replace the base gasket and torque the head bolts to 10 ft/lbs?

Re: moped wont stay running hard problem

Bobby Smith /

yeah i got the ghasket on there but i dont have a torque wrench so i dont know about that one.i dont remember a rubber seal but im gonna check again. and also what should my timing be since its got the 70cc kit on it?

Re: moped wont stay running hard problem

Don Pflueger /

timing does not need to change. your piston still reaches tdc at thesame time so it still has to fireat thesame time. by adding a 70cc kit, all you did was increase the size of the bore. if you had added a second cylinder base gasket which would have changed your port timing, then you would have needed to increase your ignition timing.

Re: moped wont stay running hard problem

Bobby Smith /

well its running now dont know why but really dont care because my moped is running. the question is, for how long will it run untill it breaks down again? thanks to all

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account