kitted puch wont fire

i had my puch on the center stand idling and warming up and somehow the chain popped off so i puit the chain back on and tried to restart it and it wont fire. its good good compression,spark and a full tank of gas but will not fire. any help is appreciated.

Re: kitted puch wont fire

try cleaning the carb

Re: kitted puch wont fire

its got good fuel flow but wont fire

Re: kitted puch wont fire

I'm having similar trouble with my puch with a 64 poloni and 15 amal. I think its my points and timing. I'd check yours. Make sure your plug is still good too.

Re: kitted puch wont fire

as terry said, put in a brand new plug, gapped correctly.

Re: kitted puch wont fire

whenever this kinda thing happens, my first idea is to connect what just happened to the new problem.. just seems logical.

Random thoughts:

Why did the chain pop off? did the piston seize?

Did the chain damage some piece of ignition related wire while it was flopping around?

Is the chain now binding or is some other part of the drive too tight?

Did the engine over-rev when the chain popped off and do internal damage to something?

Were you working on the bike or fixing something that could be related to this start problem?

If you actually have fuel and compression and spark, the engine will pop.. Use starter fluid to verify ignition and to rule out carburation trouble.

Re: kitted puch wont fire

Timmy Southpark /

sounds maybe like a timing issue, i would think with a kit you would want to advance the timing. Maybe it was just flooded, i would get a new plug, gap it correctly, then try kicking it over.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account