Morini MO-2 No Power lots O' Smoke

I've finally got my moped running. It's a 1977 Negrini Harvard with a Morini MO-2. This was a junkyard bike in really bad shape. The piston and cylinder were trashed so I found another motor with a good piston and cylinder. I have a Dellorto SHA 12 carb, and I've installed new rings.

It starts easily and runs but it produces a lot of smoke. When I take it on the road, it tops out around 5 mph.

How should I start troubleshooting?

If I installed the piston wrong would the engine behave this way?

Thanks,

Curt

Re: Morini MO-2 No Power lots O' Smoke

Edward Edwards /

The piston should have an arrow pointing towards the exhaust.

Re: Morini MO-2 No Power lots O' Smoke

Did you check to see if the exhaust was plugged? I can't imagine an MO2 at 5 mph.......I've never seen that.

First,you always gap the points after cleaning and filing them, if needed, at .012- .016" thousandths of an inch.

You always replace a spark plug at the first sign of trouble,too.

Make sure the airbox isn't clogged with a wasp nest or something aND MAKE SURE THE CHOKE LEVER FLIPS UP(OPEN), when you roll open the throttle after starting it. A stuck choke definitely causes excessive smoke and allows NO acceleration.

I may be taking a 240 mile trip tomorrow on my Sebring with an MO2, and I expect at least 35 mph,when I call for it. don-ohio (:^)

Re: Morini MO-2 No Power lots O' Smoke

Junkyard bike mufflers are often full of old gas/oil carbon crap.. Assuming you are not using too much oil in the fuel mix, that may be where the smoke is coming from.. it is burning off.

I'd start by cleaning the muffler..

Re: Morini MO-2 No Power lots O' Smoke

Curt Morgan /

I've set the gap on new points, new spark plug. The airbox is not clogged, but I haven't tried running with it removed. I live in Colorado around 5300ft and I've been meaning to remove the airbox to see if it runs better without it.

Any ideas how this engine will run with the piston installed incorrectly? The piston has a port cut into the bottom of its skirt that can either face the exhaust port or intake port. This piston was out of an old motor and I couldn't see any arrows indicating how it was to be oriented.

Thanks,

Curt

Re: Morini MO-2 No Power lots O' Smoke

The problem sounds to me like your choke is on. My Puch and all mopeds I have driven, when choke is on have the simptoms you describe. Usualy you pull the throttle all the way (and with a bit of force) and the choke should click off. If this does not work there should be another way to turn it off. If you replaced the piston and rings, focus your attention to the carb and the controls that regulate fuel and air mix, you are running to rich by the sounds of it.

Morini Mo-2 (thats a two speed never driven one but they seam to be good engines. keep at it, you should get atleast 40km.)

Re: Morini MO-2 No Power lots O' Smoke

Jason Luther /

the cut-out on the skirt should be on the intake side.-jason

Re: Morini MO-2 No Power lots O' Smoke

Allen Murphy /

Don's right on the money--I've got a Morini "MO" engine on my LEM, and I get 35-40 on demand, on flat level land.

What did you do with the old engine/parts? I'm looking for a Morini "MO" or "MO-2" to rebuild, and if you're interested in selling it, contact me.

Al Murphy

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account