problems with my engine? carb?

Kimeee Heatley /

ok... not sure what's going on... only that it's been happening for the last 5 days or so...

i have a 79 columbia commuter with a sachs engine... it has been getting up to 20-25 mph... and when she would go up hill it'd sound like she was downshifting to get up it...

now... she's really sluggish... only feels like it shifts thru 2 gears rather than the 3-4 it usually feels like... and only goes about 15-20mph tops...

the only thing i think might be wrong is that the spark plug looks like it's got a lot of carbon/sooty black on it... could this be the problem?

not sure what that means... but some *sshole broke off my engine cut off switch so now i have to use the throttle to cut the engine... is this also not helping?

as u can tell i'm new to peds but willing to get all dirty and greasy learning...

thanks for any help...

kimeee

Re: problems with my engine? carb?

Don Pflueger /

get a new plug, clean out the exhaust port and the muffler. after that, it should run much better.

Re: problems with my engine? carb?

Kimeee Heatley /

what's the best way to clean out the exhaust and muffler?

Re: problems with my engine? carb?

Don Pflueger /

most exhausts have a sheet metal screw in the end which holds the baffle tube/silencer in them. remove the screw, clamp the baffle tube with vice grips, then work it out. clean it with a solvent or degreasder, or, ive heard oven cleaner works good too. if the baffle is not removeable, build a good sized fire and roast the exhaust pipe til its cherry red. let it cool down and the tap the carbon out of it. it will then need to be repainted.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account