my moped doesn't work and i've tried everything

I have a 1980 puch maxi sport. When I was riding my moped it all of a sudden died and shut off. I have never had any problems with it before. I thought it was something electrical so i replaced the condenser and the points. I went to a moped store and the guy told me that starter coils hardly ever go bad so I left that. Before it had no spark but after I replaced the condensor and points it gained spark. But when I tried to start it it didn't start. So I cleaned the exhaust and carb. It still doesn't start. I still think it's the starter coil. what do you think??? if it is I will replace it but can anyone help me please I need to ride again.

Re: my moped doesn't work and i've tried everythin

Read the Fred's article in resource section, that is the best paper for starters.

Z

Re: my moped doesn't work and i've tried everythin

Leon Swarmer /

Billy, if you got spark its prolly not the coils. After you read Fred's guid , take a look at the following. Did you gap the points correctly and then set the timing? Did you try a new and proplerly gapped plug. Don't look for the harder stuff if you haven't tried the easy bits first.

Leon

Re: my moped doesn't work and i've tried everythin

Michael Nesson /

I have the same ped...it really needs the jet and carb to be VERY clean to run. Are you getting fuel into the carb? Try a new spark plug with the proper gap. Good luck...as Ziggy said, Fred's Guide is a great palce to start! It has helped me with all of my peds!

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account