horn and light kills engine

When ever I have my lights on or my horn pluged in my moped wont start or if it does it will die soon after. Whats going on!

Re: horn and light kills engine

It sounds like you have a short Circuit...check all your wires make sure none of them are touching the frame, or handle bars. if you have any disconnected wires cover them with tape. Then check to see if any wires are melted looking.

Re: horn and light kills engine

Ben Van Zoest /

What brand moped?

Re: horn and light kills engine

Jason Baker /

1995 Tomos targa lx

Re: horn and light kills engine

Ben Van Zoest /

Ok, I looked at several different Puch schematics the Bombadier assembled Maxi's print shows with clarity that IF the horn is internally shorted zero Ohms the horn magneto coil output which is shared with the ignition circuitry grounds the coil output, hence no run. To confirm I just looked at my Maxi I bought used recently, the slip-on connectors where taped together one has 2 green wires the other 2 wires blue and blue/black. I removed the horn and it was shorted. Were I live no one gives a crock about the horn not even a lic. plate etc. Lucky me.

Re: horn and light kills engine

Jason Baker /

same here LOL

Re: horn and light kills engine

Hey i have a Tomos Targa LX that is 1995, and i can't get it to start at all, When i peddle you don't hear anything like there is no compression, i mean the Spark plug looks fine but i don't know if like the engine is bad or what, if anyone can help that would be great.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account