Puch won't start ARG!

I recently tried to install a fuel filter on the fuel hose of my Puch Maxi. After doing so, it would not start. Thinking that the filter was obstructing the fuel flow, I disconnected it and reinstalled the hose as it was originally. The moped will still not start.

The gas gets into the carb which is clean as far as I can tell upon openning it and looking at it. The spark plug connector sparks when I hit the pedals, but the thing just won't go. It will sound like it's running only if I have the throttle cranked and am pedaling. The second I whined down the throttle or stop pedaling, the thing just dies.

What could be wrong? It was running just before I put in that damn filter!

Re: Puch won't start ARG!

Oh Jezzz...I cant imagine what the problem is??? Wow, and I heard that Puch Maxi's were such great mopeds too......Sucker! $450 bucks well spent.

Re: Puch won't start ARG!

Leon Swarmer /

is your plug new? gapped?

Re: Puch won't start ARG!

You must have had a reason to put the filter on.

Even though there is gas in the carb, the main jet is probably clogged with debris or rust from the tank. Clean your carb (Main jet) and fuel path down into the bowl and then put your inline fuel filter back on the line and it should start. Make sure to note the arrow on the filter for fule flow direction.

Re: Puch won't start ARG!

i know how u feel

same exact thing happened to my puch maxi luxe

which is still not running

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account