moped runs by itself!

I recently bought a '98 s25 LUXE (Tomos) and got it in the other day. After priming and fixing the fuel float I got it to run. I cleaned the carb and all that jazz but it runs very crappy. The idle isn't exactly an idle. I've played with the screw and have it just above barely dying. If I just sit on the bike and let it idle it will slowly take off and eventually shift into second gear! Ive tried adjusting the trottle near the handlebars but that doesn't seem to help.

Also, once the choke pops up it runs bad. You can only give it about 80% throttle. After that it acts weird, it kind of does nothing but when you let off the throttle it will make a pft and then be ok. Sometimes it will shake like mad and feel as if its going to break. It shakes and it sounds as if something is in the chain.

I really don't know what to do. I plan on taking it to a shop but I'm more frustrated than anything. When you push the choke back down it usually performs better.

If you can decipher any of my post or have any suggestions please let me know.

Thanks,

Josh

Re: moped runs by itself!

have you checked the tranny fluid? it sounds like the clutch may be sticking a bit making you take off. Does the back wheel spin when the bike is on the stand with the motor running at idle?

Re: moped runs by itself!

Yes it spins and it actually accelerates as if you're giving it gas. Does mine have tranny fluid, its a 1:50 premix.

Thanks,

Josh

Re: moped runs by itself!

yes it has tranny fluid, the premix lubes the piston and the rest of the top end, there should be tranny fluidin the bottom end, I think Sachs may use 30 weight motor oil, I'll have to look real quick, well it says type A or F ATF will work, I think the manual says type F. search the forum for "sachs fluid" under all dates and it will tell you how to fill it, I would suggest not riding anymore untill you check the tranny fluid, it could cause serious damage. If the wheel spins and the motor is so slow its about to die, the clutch probably is sticking

Re: moped runs by itself!

You have an air leak, that's what's causing the accelerating idle. Hold the throttle at a steady speed while it's on the stand and spray carb cleaner around the carb, intake, and cylinder (where the gaskets are)...if your engine dies when you spray a certain spot, there's your leak.

Re: moped runs by itself!

In the morning Im gonna go get a new spark plug and then see if it is an air leak. A sticking clutch AND the air leak sound right, b/c it shifts HARD and sometimes it does stick, kinda like when you first learn manual cars and you almost stall them but it tries to hop like you have hydraulics. Hopefully its one and not the other.

Thanks guys.

-Josh

Re: moped runs by itself!

You are definally running very lean. Try getting a larger jet 6 sizes up and see if that helps.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account