puch engine

Rayn Kozikowski /

today i put my engine back on my puch magnum and i was working on it for 3 hours and it still wouldn't start. i checked everything but it doesn't seem like any gas is getting to the cylinder. i can hear it trying to turn over but it never does. i think the problem is in the carb but i dont know what to do about it. does anyone have a clue?

Re: puch engine

you didnt list "everything" you tried so this answer may be useless..

i would spray some Starting Fluid (spray can at auto parts store) into the air intake or into the carb .. it should run for a few moments.. then you can be sure the engine is not getting gas for some reason..

and/or

pull the spark plug out and connect the spark plug wire to it and clip the plug to the engine (ground it).. try to start and watch the plug.. you should see little sparks.. if not, you have an electrical problem.

also check for compression.. pull the sparkplug and plug-up the hole with the end of a rag (or your finger) and try to start.. the rag should pop out.. if not you have some kinda mechanical problem.

Re: puch engine

Rayn Kozikowski /

nothing seems to work. the back tail light is not going on when i try to strat the moped. but i know it does normally. i checked the bulb and it works fine. i also have a strong spark. it is leaking gas out of the exhaust port and out of the float bowl. whats going on ??????????????????????????????????????????????????????????????????????

Re: puch engine

Carb's flooding for one thing. Needle valve or float isn't sealing right.

If you have a strong spark, get the bike started and then worry about the taillight. Is it a 6 volt,5 watt bulb? don-ohio

Re: puch engine

Rayn Kozikowski /

6 volt 10 watt but it works fine when i put a 9 volt to it

Re: puch engine

You didn't mention why you had that engine off in the first place.. How about some history of whats happened and the way the bike has been running lately.. the time between when it was running fine and things started going bad.

Re: puch engine

Rayn Kozikowski /

i took the engine off around christmas time because i was getting my 70cc bore kit but i diddn't have enough money. since the weather is nice i wanted to drive it .but now i am having a ton of problems

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account