tomos A-3 engine troubles

Ian Steedman /

Im haveing trouble with my 1980 tomos A-3 Bullet, the engine will not idle and has no power when im on it. When it is on the kick-stand i can rev it up and get seccond gear to kick in, but the throtle it verry un-responsive and when im rideing it i have to keep the throtle all the way open and it accelerates verry slow. I tryed to run it without the exhaust pipe on it and it ran somewhat ok, I still had to keep the throtle open all the way, but i got into seccond gear and got up to 25mph. It still wouldent idle but it tryed to. Any one got any ideas or maby had the same problem?

Re: tomos A-3 engine troubles

First,make sure the exhaust pipe and exhaust port at the cyl. are not restricted with carbon. Also check that the points are set to .016" and not pitted, and the spark plug should be new. Tranny fluid should be at proper level and be clean. don-ohio (:^)

Re: tomos A-3 engine troubles

Ian Steedman /

The spark plug is new and the points are set to .016", Im trying to get new exhaust because I can't get the carbon out of the pipe. But what is the correct level for the tranny fluid, how do i tell??

Re: tomos A-3 engine troubles

Should be a level checking screw in the tranny side cover. Fill to that level. Probably 250cc will do it.

To decarbonize the exhaust you roast it in a fire, shake it out, and then re-paint it. don-ohio (:^)

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account