FA-50 bogs at full throttle

Larry Buyan /

I've got an older FA-50 (suzuki) that starts bogging at full throttle. Any ideas as to what the problem might be. Runs great at lower throttle positions. Also bogs from standstill when throttle opened wide.

Thanks

Re: FA-50 bogs at full throttle

FIRST...always replace spark plug.....Is choke releasing all the way? Exhaust pipe and port clean of carbon? Air filter clean? That wacky fuel valve in the right position? don-ohio

Re: FA-50 bogs at full throttle

hey mine does the same thing, i cleaned the carb though and it stil does it till it gets warmed up then it runs good. have you tryed letting yours warm up good? also try messing with the air mixture screw and idle screw. if you need a diagram of the carb i can post it.

Re: FA-50 bogs at full throttle

Larry Buyan /

Hi,

Thanks. Yes I do need a diagram. It doesn't have an air cleaner and there are one or two vacum hoses not installed (correctly?). It does run better warm. Has a new plug too.

Thanks.

Re: FA-50 bogs at full throttle

Larry Buyan /

Thanks for the reply. Has a new plug. Runs better warm. I don't have an air cleaner/housing...didn't come with one. What does the wacky fuel valve look like? Is it some sort of a reserve type valve?

Thanks again!

Re: FA-50 bogs at full throttle

hey i have the find the pic but heres a website that will help http://www.ural.com/uralmanual/ch_5mikuni.htm it has a diagram too.

Re: FA-50 bogs at full throttle

Mikel i think your problem is not having an air cleaner

Mine did the same thing

You would not believe the difference the stock fa50 aircleaner will make on your ped. not only in performance. but when I put that thing on it was twice as quiet.

Re: FA-50 bogs at full throttle

Larry Buyan /

Thanks! That's what I thought so I fashioned one out of a lawn mower filter I had laying around (just for trouble-shooting) ...no help.

Say there are a couple of vacum lines hanging. Do any of these go to the air cleaner?

Thanks!

Re: FA-50 bogs at full throttle

Larry Buyan /

You know...I took the carb apart and cleaned it (new plug too). It seems to me to be a problem with the choke not working correctly. Do you know how the plunger/choke assembly comes apart? I was unable to remove the choke cable from the carb...no problem removing the throttle.

Also, when I rev the bike I notice gas spitting out the carb where the air filter attaches to the carb.

Thanks for your help!

Re: FA-50 bogs at full throttle

Mikel.........I don't see where you checked for a blocked exhaust port and muffler? Could it be that? I mentioned it earlier. don-ohio

Re: FA-50 bogs at full throttle

Larry Buyan /

Thanks Don,

No I haven't yet. There is pretty good exhaust (white--carb cleaner) coming from the tailpipe so I was thinking the exhaust was probably OK. I'll probably do it tonight. Say, did you se my post regarding the choke. I took the carb apart last night and cleaned it. Couldn't get the choke cable off of the carb (I didn't want to force it). Is there some trick to getting the carb and choke cable separated?

Thanks!

Re: FA-50 bogs at full throttle

I dunno,Mike! I have always wanted to know what makes those things tick,ever since WENDY( a really nice girl married to JimK) blew us all away on the FIRST `Ike's Ride' on the hills with an FA50. I want to get a shop manual for one soon. don-ohio (:^)

Re: FA-50 bogs at full throttle

Edwin Johnson /

I got my boxer 2 running and it was doing same

turned out a plugged exhaust and erratic fuel delivery

Re: FA-50 bogs at full throttle

Larry Buyan /

Checked the exhaust last night. It's fine. Sounds like I may have a problem with 4 stroking though.

Re: FA-50 bogs at full throttle

You need to get a stock air filter I am telling you that is your problem. I had the same problem. You will thank me if you do. go to bikebandit.com and order one. I promise promise, If I am wrong you can bash me here in this forum I am telling you that air box you made is your problem. get a stock filter and housing and all will be ok

Re: FA-50 bogs at full throttle

Neil Richardet /

I had the same problem and I 100% agree that the Suzuki FA50 needs an air filter and the cover ( preferably stock ) or it will "bog" whenever you give it full throttle. The reason is that without an air filter, it gets too much air. With an air filter and the proper cover and housing, the mix is correct ( rich enough ) for perfect running. You can prove it by putting the choke on full and it will run up to about half throttle before it bogs. I had to use a coffee can cover and cut a 1 inch hole in it because my air filter cover is missing. I need one if anyone has one.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account