75 Puch Runs but I need Help

Well Success is almost mine!

I got my newly aquired Moped to fire and run for the first time tonight - YAY - first time it has run since?

Anyway - Here's the deal - I can't keep it running just right -

Problem:

Going down hill, it will move right along and keep the revs up. Going uphill or under load, it lacks power.

Could it be:

1) Idle screw not set right?

2) SparkPlug Gap?

3) Weak coil?

4) Poor compression?

5) Did I overlook something or miss it completely?

If I pick it up, it will rev right up, but then begins to bog out. I have to keep reving it up and down to maintain power.

Any and all thoughts greatly appreciated. I am new at this, so please be gentle!

Re: 75 Puch Runs but I need Help

Do you have the air filter on the carb? Got to have one. If you have one , clean it if there is a round wire mesh in the side hole of the air cleaner.

Is the black stem on top of the carb pulled up all the way? This is the choke. You are supposed to push it down by hand when you attempt to start the bike. The choke stem is supposed to come up all the way when you twist the throttle full range. If it doesn't use a little WD40 and some fine steel wool to polish the choke stem so it slides up and down properly.

Did you check the oil in the transmission? Puchs have a wet clutch. Puchs made a one speed (round external cover on right side of engine) and a two speed (oblong or rectangular cover on right side of engine.)

1 speed takes 5.5 ozs of ATF type "F" . Filler screw, slanted screw on side of cover near the bottom.. If ATF runs out it's full.

2 speed holds 9.5 ozs ATF type "F", plastic twist type filler plug on top of tranny case. Use only 9.5 ozs. (DON'T top it off or overfill it)

Did you oil your chains and is the drive chain on the left side adujusted to the proper tension.

Are the brakes adjusted too tightly?

Re: 75 Puch Runs but I need Help

HI Zippy -

Yes - the round wire mesh filter is there and it looks clean - but I don't have the airbox.

Choke is working fine - the black lever is missing, but I can still reach in to push it on and it does kick out. I have had the whole carb apart and cleaned it.

Chains and brakes seem right.

Haven't got to the transmission yet, but I'll bet you are right, it likely needs dumped and changed.

Thanks.

Re: 75 Puch Runs but I need Help

Sounds like a clogged muffler. Take the baffle out and clean that sucker good.

Re: 75 Puch Runs but I need Help

Not sure I understand how you could have the round mesh filter with no air box. The stock air filter for a Puch Maxi is a flat black plastic air box about 8" by 4" which sometimes has a round metal wire mesh filter that fits in the moped side of the air box. Sometimes there is also a flex tube that goes up into the round hole in the frame of the moped.

The other end of the air box attaches to the carb.

It won't run properly without this air box filter.

Re: 75 Puch Runs but I need Help

Mike Monigold /

I've got a 1977 Puch Maxi S that I just got running. When I drained the transmission to put new type F oil in it, it had less than a tablespoonful of oil in it!

It still has a carb gas leakage problem though. I'll mess with that tomorrow.

Re: 75 Puch Runs but I need Help

Zippy,

In the carb inlet there is a round, fitted wire mesh filter.

I do lack the air box though - if you or some one has close-up pictures of what this airbox looks like, I would like to see them so I know what I am missing.

Thanks!

Re: 75 Puch Runs but I need Help

Here you go. Your's should be like the one in the exploded view or air box "A" in the pic.

http://www.themopedjunkyard.com/puchairbox.html

Re: 75 Puch Runs but I need Help

If your Maxi is a 1 speed you'll need to refill with 5.5 ozs of ATf type F.

Re: 75 Puch Runs but I need Help

Mike Monigold /

Yep. I refilled with the correct amount of type F. I had no idea that there were different types! Good thing I looked at the bottle that I already had - it wasn't type F.

Had to order a used carb body and bowl from Ike. My threads were stripped on the body and the bowl. Someone overtightened it to stop the gas leak when they should have replaced the gasket instead. Oh well........

Re: 75 Puch Runs but I need Help

Thanks Zippy!

Much appreciated.

If I can find one of these and get it bolted on, I should be good to go.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account