Ciao Power Failure

I was riding around on my Ciao the other day, and the headlight went out .. i looked at the rear, and it was out too. It starts kinda randomly fading in and out, and then after a little bit just turns off completely. What could be the problem with this? I looks like it has a brand new coil, and I've yet to have any power issues.

Any ideas?

Re: Ciao Power Failure

Bruce Wilkinson /

Is this the same Ciao that you had the switch problems with ? Take the bulbs out and look at the tiny wire filaments inside the glass to see if it's the bulbs are burnt out ,or if it's something else. bruce

Re: Ciao Power Failure

okay, now it's gotten weird..

So everything is wired correctly ... according to Fabio and the charts ...

When i start the moped no lights work .. but when i pull a brake.. the headlight very dimly comes on, and the brake light doesnt work at all...

It looks like somehow its crossed with the brakelight mechanism ... but i dont see how i could manage to do that ... i didn't really change anything

Re: Ciao Power Failure

Bruce Wilkinson /

Sounds like you did something wrong in the wiring. I don't have brake lights on mine. REcheck it, what can I say. bruce

Re: Ciao Power Failure

Switch the positions of the blue and green wire on the tail light assembly.

Re: Ciao Power Failure

Alright I double checked all the wiring with Fabio from vespa super shop .. he said everything sounds good. I swapped positions of the taillight wires (green and blue) and it does the exact same thing. Fabio suggested i double check the grounding wire on the engine ... everythings intact.

So after inspecting a little more, it doesnt seem like much power is getting to anything. i pressed down on the horn, and instead of its sharp little toot, i got a dying sputtering sound that sounded like a seal. Could it be something like I need a new battery??

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account