WTB ZA50 roller springs

Not 100% sure what they're called, but I'm looking for the little springs that hold the roller bearings into the first gear and allow first gear to engage. Mine are old and weak and not working properly. Can anyone help me out?

Re: WTB ZA50 roller springs

mopedcrankworks.com - /

I have them. How many do you need? Email me.

Re: WTB ZA50 roller springs

Chris, I clicked on your name, but I can't find an email address. I'm probably just tech-retarded, but can you email me at ElizabethDCunningham@yahoo.com?

Re: WTB ZA50 roller springs

Okay. I guess I couldn't find it because I wasn't signed in. Once I signed in, it showed up.

Re: WTB ZA50 roller springs

top

Re: WTB ZA50 roller springs

I highly doubt that they're worn out. Do you have the rollers on the wrong side of the springs? Post a picture of it if you can.

Re: WTB ZA50 roller springs

They're certainly on the proper side. I honestly don't even know if they're the problem. In the past, the retainer got turned around and the roller bearings came out and did unhappy crunchy things, even broke some springs. So, it's quite possible that the surviving springs are damaged. Anyway, I have a post in repair about why it won't engage sometimes. What's got me is that I'm getting lots of not happy metalic noises when it finally does engage. Don't have any idea what it is... :(

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account