Wrong mount?

Yeh i have a biturbo for my targa and i was wondering if the store could have sent me the wrong mount or the pipe is bent. The gasket matches up but when i tighten it up all the way there is a leak. Because when i put it on i started it up and plugged the end and it was still running could hear leaking out near head. But its tightened all the way will this be ok? Or will it hurt the engine? If so how can i fix it?

Fox

Re: Wrong mount?

Assuming they gave you the right pipe.......

The best way to fix it is to find somebody with an acetylene torch.

(propane torch's won't get hot enough)

Lay the bike on its side.

Disconnect the rear "hanger mount" of the pipe.

Bolt up the front mount (to the cylinder). nice and tight and inline.

Then heat the header pipe (up near the cylinder) all the way around, till it turns an orange color.

Then grab the back of the pipe and bend the pipe till the rear hanger mount lines up with its bolt hole (and you may have to drill a new hole).

That is the correct way.

The problem will be finding somebody with a torch who will do it for you.

Re: Wrong mount?

this smae problem happen on my tomos. it doesnt seem to hurt it. maby buying 2 gaskets to seal it will help?

Re: Wrong mount?

I'm just curious, as my BiTurbo doesn't match correctly. Why heat up the pipe at the bend nearest the cylinder. I've heard somebody else mention that too. It seems that the corner nearest the cylinder already has the most radical bend to it.

Wouldn't heating up the lower bend be better for the flow.

A friend of mine works at the local muffler shop, so I'm going to have him bend

my pipe and weld the two pieces together.

Re: Wrong mount?

Don Gotti /

obviously u have the wrong pipe dumb ass if its a 2 piece pipe thats the one for the big bore 70cc kit,,,i have the one piece and its fine....can u walk under cars??

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account