Got it running recently

Hey guys I have recently finished (nearly) restoring my Batavus starflight 2. the VA2 model. Haven't put the saddlebags on yet, and I need to fix the rust on the headlight housing and handlebars still, but I'm very happy to be pedding atm.

I'm gearing up for a ride around here (lancaster pa) on the 19th I'm told. I have yet to register/title my ped, but I heard that I might be able to at this event. I had to re-set the points, clean the piston of carbon, and do small wiring fixes to get her running, OH and the petcock was bad so I got one off Ebay (twas a universal one). I'm having trouble figuring out what oil/gas ratio I should use because I used the reccomended 40:1? and I think my plug was oil fouled. I don't remember though I'll get my local friends to help w/ that.

Anyway, on with the pic and a small vid.

<a href="http://s116.photobucket.com/albums/o37/didderson/?action=view&current=mopednew2.jpg"; target="_blank"><img src="http://i116.photobucket.com/albums/o37/didderson/mopednew2.jpg"; border="0" alt="Photobucket"></a>

<embed width="448" height="361" type="application/x-shockwave-flash" wmode="transparent" src="http://i116.photobucket.com/player.swf?file=http://vid116.photobucket.com/albums/o37/didderson/mopednew.flv">;

This pic is kinda old, it has the luggage rack on it now and a brand new drive chain thats a sweet shade of silver.

None of the finish is original except for the black on the frame tubing and front fork. The orange is flourescent orange like a street cone. The chrome was all rusty so I sanded it and resprayed a crappy silver.

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).