My moped runs TOO well!!!

So I was just about to ride around and go get food later, but not even one minute after I got going, I got up to about 35 and my headlight blew. I hit it a few times to see if it would turn back on, but no dice.

Then, turning around, my tail light blew. And of course, not even 30 seconds later, my speedo bulb blew!!!

Gah! I'm so angry! I wanted to ride and my moped just hates me this week with not starting and running well yesterday, then being fine and now this!!!!

I guess no Spokesmen ride for me on Friday unless I get this fixed.

Re: My moped runs TOO well!!!

use motorcycle LED's i havent, but i imagine they last way longer and are better in every way.

Re: My moped runs TOO well!!!

LED's are 12v, not 6v. However, Zack Spoke has used LED's for a tail light before.

Re: My moped runs TOO well!!!

You can get 6V or 12V LED's.

Re: My moped runs TOO well!!!

you can use 12v LED's on a 6V system and they will be bright as hell. it really isnt that big of a deal. or just make your own. this will show you how

Re: My moped runs TOO well!!!

my guess is that if you have a battery, its dead or dying...it acts as a voltage restrictor on some set ups. if not then loose wire, shorting out? Seems odd that they all went at the same time...

Re: My moped runs TOO well!!!

Where did i just read this? I think it was actually in the Puch repair manual downloadable at mopedarmy. It warns that the way the mag is set up, blown bulb should be replaced at once or the other bulbs are at higher risk. Perhaps they take on the extra load? I wonder if this arrangement would cause similar problems with leds.

Re: My moped runs TOO well!!!

yup, if the speedo bulb or the headlight bulb blows, it has to be replaced, or the other bulb will blow because there isn't enough resistance in the circuit. Joe

« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account