horrrnnnnnn isss stuckk onnnnn

so i got a puch maxi. this is my first moped. i just got it running and i was wondering wht the buzzing noise coming from the from was. well its the horn. and when i disconnect it it shuts off. dang it. so wha should i do. new horn? maybe a wrong wire or sumthing? idk help please.

Re: horrrnnnnnn isss stuckk onnnnn

the horn sucks just take it off

Re: horrrnnnnnn isss stuckk onnnnn

uuuuuuuuuuuuuuuuuuuuuuuuuuuuuuunnnnnpluuuug it then, it that to hard?

Re: horrrnnnnnn isss stuckk onnnnn

and read about re-wiring your moped to make work with no horn

Re: horrrnnnnnn isss stuckk onnnnn

if i unplug the ped shuts off.

Re: horrrnnnnnn isss stuckk onnnnn

hahaha kinda like little miss sunshine with that damn van... hahaha love it.

Re: horrrnnnnnn isss stuckk onnnnn

the obvious temporary fix would be to just take out the horn and connect the two wires that went to it, but since that'd leave you without a horn . not that the average car user can hear a stock horn. the best thing to do is re-trace your wiring and make certain that everything is in it's correct place, sorry that's pretty much the best i can advise.

you could also re-post this in the repair section...

Re: horrrnnnnnn isss stuckk onnnnn

un plug the two connectors, then connect those to eachother. i think that will work

Re: horrrnnnnnn isss stuckk onnnnn

yeah thnks. i tried in the repair section but they take forever to respond and no one responds to my stuff in there. thanks for the advice guys.

Re: horrrnnnnnn isss stuckk onnnnn

there should be threads on this already, but just cut everything you dont want off the harness.

you only need 2 wires to make it run. ( Blue and Blue/Black )

3 and 4 if you want headlight and tail lights ( Yellow and Grey )

Re: horrrnnnnnn isss stuckk onnnnn

Yeah just take the horn out and connect the wires to each other.

Or, leave it like that and get one of those horns that plays music.

--Scott

Re: horrrnnnnnn isss stuckk onnnnn

this is one of most common issue on old puchs that have been rusting for a while. the rust inside the horn is the problem. if you spray a buncha wd40 in that bitch let it sit then whack it it will totally work again. not kidding done this at least 6-7 times.

most people just disconnect them. i know i do. i havent had a working horn on a bike in i dont know how long. tune your shit and rev your engine at people instead. my bike is louder than any horn on the road.

Re: horrrnnnnnn isss stuckk onnnnn

i know it really not tht loud it just annoying. and i think u guys r right with the music horn. my bro has one. maybe ill rig it up and play it at people for shits and giggles.

Re: horrrnnnnnn isss stuckk onnnnn

This is what I had posted on Moped Riders. Do a search there for your horn problem. This post can be found by searching for "yodasen" as the author.

Thanks guys for the responses. I got it fixed now! There is only one Blue/ Black wire going to the switch on the handle bars from the horn. I disconnected that wire at the switch and grounded it directly to the handle bars and the horn stopped buzzing. Pull the wire off the handle bars and the horn blows! The final fix was to clean the all the connections on the horn switch and also cleaned the mounting clamp that attaches the switch to the handle bars to ensure a good ground.

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).