Moped idle RPM; Tiny Tach fried

For those using Tiny Tachs or others, should a moped tach read 6,000 at idle (I have a TFR, stock)??? I don't think it should. However mine did. And like a dumbass I rode it and fried it as it went past 10,000. I rode 2T race karts at Bondurant with powerbands at 9000, and they flat out screamed compared to the humble little stock TFR engine.

Methinks two things - I got the wrong one maybe, and obviously I shouldn't have gone off and ridden it. But ... WTF basically. I initially thought maybe it was reading 2x what it should because I wound the inductive pickup wire around the plug wire too tightly (close together) but nope...

Re: Moped idle RPM; Tiny Tach fried

i think its running 6 times too fast but thats just me i think you got the wrong one or you set it up wrong

Re: Moped idle RPM; Tiny Tach fried

I know I didn't set it up wrong... very simple. I even re-checked ground and pickup. I think they sent me a 1C (spark every 180 degrees of the crank) or a defective unit.

So idle, as I thought, should be in the 1000-2000 range, somewhere in there?

Re: Moped idle RPM; Tiny Tach fried

it should only spark every 360 degrees unless you have a 2 cylinder moped yes idle should be in there, does your idle sound high?

Re: Moped idle RPM; Tiny Tach fried

I imagine your idle should be around 1500rpm and something like 7500-8000 WOT.

Re: Moped idle RPM; Tiny Tach fried

It's a 1-cyl, kept in good tune, electronic ignition (maybe that's why?). The idle has sounded almost exactly the same for almost 3000 mi.

Re: Moped idle RPM; Tiny Tach fried

Yeah, exactly that's what I thought... I thought of my best-ever downhill bomb toward a police radar sign, when it read 41 mph and the sucker just wouldn't rev any higher. Then I compared that to the race karts, and figured I wouldn't exceed about 8000. Crap, now I've either wasted $40 or in some odd fashion will be able to convince the mfr. their product was defective.

Could electronic ignition be the reason why it failed?

Re: Moped idle RPM; Tiny Tach fried

It's not fried, just needs to be reset. I had four windings across the plug wire, and it read 4x what it should have (6000 at idle rather than 1500). I will try again tonight. The only other thing he suggested was that perhaps the plug fires twice / rev which I don't think it does...

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).