So simple yet so hard...

I have a problem and I believe its simple to fix...but I don't know how. Whenever I startup my ped with minimal throttle it runs fine, but if I give it anymore the engine kicks into high gear and wont respond to the throttle any more, so I have to hit the kill switch to shut it off. What do you think the problem is? I have a feeling its because my throttle cable my be to short or something like that...but what you all think?

Kuro Neko Neko

Re: So simple yet so hard...

Edward Richardson /

Your slide is jammed in the up position, remove the top of carb and readjust.

Re: So simple yet so hard...

Kuro Neko Neko /

Thats what I thought, thanks for the response.

Kuro Neko Neko

Re: So simple yet so hard...

No a trans problem /

I thought I had that exact problem, but it turned out to be a fuel blockage which allowed a smooth idle, but bogged terribly when I turned the throttle, making me think it was stuck in second gear. If was only after much work and searching that I accidently discovered the real cause. First, try cleaning your carb's fueld filter, and if that doesn't work empty your gas tank, take out the filter if one is there, give your tank a little flush, clean your filter well, taking it apart to clean if possible. Clean your carb's fuel filter again after this. Oh .. the blockage might also be in your jet, or in your spray bar, if your carb has a spray bar.

Re: So simple yet so hard...

i had a problem like that as well. i kept checking the carb and making sure everything was fine and then when i started the bike it was stuck on full throttle and wouldnt change. it turned out it was because my throttle cable was uber frayed. new throttle cable = sextastical fun times.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account