Testi questions.. and 15yrs not running

Richard Woodford /

Ok all , looking for some answers to some questions.

First off after 15 yrs not running and boxed up should I have 185psi in the cylinder? second, after all this time and less than 650 miles, should I be concerned about a "second" break in period?.. grl runs strong and havent had any idle/ dying problems. If I need to run less than the 50:1 I used to use yrs ago or?

Without getting to far ahead... is it normal for a suposed 30mph ped to go 39-41 on flat ground stock? Whats the deal.. I thought it strange when I tooled around on it yrs ago but after getting her back together she still tops out around there.<39-42>. <followed by cop friend and also GPS> whats up ? any ideas

Thanks in advance

Richard

Re: Testi questions.. and 15yrs not running

Richard Woodford /

Forgot to state this is a minerelli V1, 16mm carb, but just a crate bike i got long ago

Re: Testi questions.. and 15yrs not running

all sounds normal and i doubt u have to re brake in a moped

Re: Testi questions.. and 15yrs not running

just ride it! 2 stroke do not like to idle anyway, ride her like you stole it! use good oil synthetic is best from what I have heard, but castrol 2t is awesome as well, if you have her running riding you are well ahead of the curve so to speak! Look up your bike on here or moped riders association website for the corect mix! best of luck to you!

Re: Testi questions.. and 15yrs not running

Jason Luther /

you guys totally missed a great 'insert joke here' moment. but are those components stock?

Re: Testi questions.. and 15yrs not running

Richard Woodford /

they should be stock.. I would figure since they were sealed in the crate when it was new.. am I missing something?

« Go to Topic — end of thread

Want to reply to this thread?

We'd love to have you join the discussion, but first you'll need to login (or create an account).