E50 runs like shit saga

Puch Maxi S 78 ran perfect this morning, 40km/h uphill, good acceleration. Then it was W11, 37 idle jet, 76 main jets, needle clip second from top, BRPH9S. Ran perfect. When engine got warmer it then bogged down and wouldn’t start. So it would run on the choke, but nothing else. Changed to a bigger main jet, nothing helped. I tried 110 jet for fun and it even runs on that wtf.

So 76-77-80-82-86 and so on runs like shit. It’s a 17,5 mm phbg. 60-68 main jet makes carburetor backfire. But once engine was warm it would run like crap.

Dmp 2.0 all round

17,5mm phbg, 260 AU, two stroke atomizer.

Biturbo

PSR 70

Re: E50 runs like shit saga

If it’s running on a 110 you may have developed a monster air leak, build a leak down tester one of the best tools you can make,

If it gets hot, shuts off/ but then starts fine when it’s cool sounds like a classic condenser issue

Re: E50 runs like shit saga

Dirty30 Dillon /

Yeah, you have a huge airleak. Hard start and run on choke when hot indicates to me something is expanding open when heated.

Re: E50 runs like shit saga

> Nathan Wizard wrote:

> -------------------------------------------------------

> If it’s running on a 110 you may have developed a monster air leak,

> build a leak down tester one of the best tools you can make,

>

> If it gets hot, shuts off/ but then starts fine when it’s cool sounds

> like a classic condenser issue

Monster airleak you say. if it was no airleak it wouldn’t even crank and fire with 110 jet?

It’s strange it ran so good and perfect uphill with W11, 76 main jet, 37 idle jet and once it was warm it bogged down. I thought it was the other way around a 2 stroke would run shit cold but once warmed up it runs smooth. So this indicates airleak?

Re: E50 runs like shit saga

> Dirty30 Dillon wrote:

> -------------------------------------------------------

> Yeah, you have a huge airleak. Hard start and run on choke when hot

> indicates to me something is expanding open when heated.

Yes makes sense. wonder what it could be, Where can air leak in on least expected areas? Can clutch cover mess up with airleak into crank housing?

Re: E50 runs like shit saga

I don’t ignore what you said about condenser,

Re: E50 runs like shit saga

Moped runs fine for now. Need to get a pwk

Re: E50 runs like shit saga

Dirty30 Dillon /

The PHBG is not the problem.

Re: E50 runs like shit saga

> Dirty30 Dillon wrote:

> -------------------------------------------------------

> The PHBG is not the problem.

I’m running W7, 78 main jet and stock idle jet. Perfect color on spark plug, gapped correctly. Timing is 20 degrees, 0.40mm ping gap. Coil gapped, good compression and blue spark. Tried three different carburetors. Phgb seems to respond good on WOT. No air leak. believe me, there’s no airleak.

Problem seems to be solved for now.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account