1977 Puch Maxi Light Issues

Benjamin Wheeler /

I recently dusted off and got my 1977 Puch Maxi running after a short 17 years of neglect. However, my headlight, taillight, and brake lights are not working. Interestingly, the horn is.... The on/off kill switch seems to be fine as is the speedometer, but no lights on the speedometer either. Before I cause any issues I was hoping to get a few tips on what path I should start down in an attempt to get the lights operational. Any advice is appreciated. Thanks!

Re: 1977 Puch Maxi Light Issues

Have you checked the bulbs?

Re: 1977 Puch Maxi Light Issues

Google Puch Service Manual

Re: 1977 Puch Maxi Light Issues

Dirty contacts in the switch and bulbs.

Re: 1977 Puch Maxi Light Issues

Check bulbs first to see if the filament is intact, then the contacts in the housing, then the connection points for the power and ground wires. More than one bulb might be part of a given circuit (like I think the speedo bulb is part of the headlight circuit) so replacing one might fix them all.

Re: 1977 Puch Maxi Light Issues

Benjamin Wheeler /

Thanks for the ideas, much appreciated. I went ahead and checked the switch connections, see images below. There was a little rust, so I cleaned up the connections to be best of my ability and still no lights. I was able to get some sparks from the blue and green wires and the switch, so it appears the wires are connected to the coil. The blue and green wires were in a simple wire cap. Do these need to be grounded or attached to the switch? That aside, I think the switch connections are correct. At least the horn still works....

My next step is the check all the bulbs as was recommended. I'm hoping these are easy to replace. Any further ideas would be great.

Ben

IMG_6577.jpg
IMG_6576.jpg
« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account