E50 wiring question

Kyle Washburn /
This single post is part of a larger thread. Start from the top or view this post in context.

Hey guys,

Have had some trouble getting my puch running. I installed a new condenser (solder type) because my bike would die once it got warm as if there was no spark. Here is my setup:

Treats 70cc kit

Mikuni vm20 with 130 main and 2.17 idle

Leanest needle clip setting

Proma circuit

17x45

The bike will start and idle, but seems very rich/laggy when I give it throttle. Plug is black and sooty. It has terrible low end and will eventually die. Got it to stop backfiring out the carb by resetting my points gap. Timing is set to 17* btdc, I've checked for air leaks, tried a new plug, so I'm thinking it's something to do with ignition. Can't seem to get this thing ripping. Here is a photo of the stator wiring. I think there could be a bad ground somewhere but I have no clue how to check that. I just redid my wiring as I eliminated everything but headlight and tail light, so everything seems to be in the right position. (edited)

IMG_20200620_145134.jpg
This single post is part of a larger thread. Start from the top or view this post in context.
Subject Written By Posted
  E50 wiring questionTopic by: Kyle Washburn Kyle Washburn 06/20/20 02:57PM
  Re: E50 wiring questionRe: todd amundson todd amundson 06/20/20 03:03PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/20/20 03:06PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/20/20 03:10PM
  Re: E50 wiring questionRe: * wormdirt * * wormdirt * 06/20/20 03:08PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/20/20 03:12PM
  Re: E50 wiring questionRe: Brandon Love Brandon Love 06/20/20 04:19PM
  Re: E50 wiring questionRe: pat splat pat splat 06/20/20 04:34PM
  Re: E50 wiring questionRe: Brandon Love Brandon Love 06/20/20 04:49PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/20/20 08:39PM
  Re: E50 wiring questionRe: cheetahchrome . cheetahchrome . 06/21/20 12:49PM
  Re: E50 wiring questionRe: Graham Motzing Graham Motzing 06/21/20 09:49PM
  Re: E50 wiring questionRe: Graham Motzing Graham Motzing 06/23/20 04:21PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/23/20 04:41PM
  Re: E50 wiring questionRe: Garrett The Kid Garrett The Kid 06/24/20 10:31AM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/24/20 10:55AM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/22/20 09:50PM
  Re: E50 wiring questionRe: roy jongejan roy jongejan 06/22/20 10:05PM
  Re: E50 wiring questionRe: pat splat pat splat 06/22/20 10:21PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/22/20 11:06PM
  Re: E50 wiring questionRe: Aaron Blair Aaron Blair 06/22/20 11:27PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 06/23/20 12:05PM
  Re: E50 wiring questionRe: roy jongejan roy jongejan 06/23/20 12:26AM
  Re: E50 wiring questionRe: Jay Rivett Jay Rivett 06/24/20 09:09AM
  Re: E50 wiring questionRe: Sir Clip Sir Clip 06/24/20 04:23PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 07/05/20 11:03AM
  Re: E50 wiring questionRe: Dirty30 Dillon Dirty30 Dillon 07/05/20 11:43AM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 07/05/20 12:11PM
  Re: E50 wiring questionRe: Kyle Washburn Kyle Washburn 07/07/20 09:09PM

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account