vespa bravo not running well

So just got a new Malossi high flow air filter along with a throttle cable for my 77 bravo. I installed both of them today and cleaned the carburetor in the process. I then started the moped, it will now start up fine but it idles a bit slower than normal. Upon giving it a bit of throttle the engine begins to die as more throttle is applied nearly dying at full throttle. what could this be? Too much air now, requiring me to up-jet to maintain the proper ratio?? Did I crack the plastic intake manifold?? (edited)

Re: vespa bravo not running well

Do you still have your old filter? Try it and see. Stock Vespa's have small carbs and/intake windows. Some don't like the extra air.

Re: vespa bravo not running well

If your not kitting your bike keep the old filter. And yes, of you change anything. Carb, exhaust, filter you need to re-jet.

Hi-flow = more air, your running in a lean condition.

Re: vespa bravo not running well

Only you can tell what happened, way way too many variables. Was it running good before? Did i break the clamp, did i mess up the float? Did i mess up the throttle cable? Did i strip the fuel banjo? Did i even take the fuel banjo and filter off? Do i even know theres a fuel filter in the banjo? What is a banjo?, must be some kinda musical instrument thats part of the main, etc. etc, etc.

Best to be moped careful explain as much detail as possible, what carb size, main jet, speed before after, etc, etc.

Did it run better before? if so put the og air filter back on.

If it did not run well then an air filter/throttle cable is not gonna fix your problems.

To test if your lean, choke running motor until close to dying and the throttle wide open, if the motor revs up faster/better then your main is too small.

Re: vespa bravo not running well

Vespas are so picky about air/fuel mix. You’re lean. Upjet.

Re: vespa bravo not running well

Pat I looked on his profile, he's got some type of plastic bottle for a tank. Maybe his cap doesn't have a breather, could that be a problem?

Re: vespa bravo not running well

> Les B. Wrote:

> -------------------------------------------------------

> Pat I looked on his profile, he's got some type of plastic bottle for a

> tank. Maybe his cap doesn't have a breather, could that be a problem?

^^exactly, more possible issues, who would've guessed that a windshield wiper bottle was his new gas tank.

Re: vespa bravo not running well

Nate Lesan /

I dont believe I will "kit" the bike, but I want to try and increase top speed to around 30-35. I think I will upjet is there a systematic way to decide which size to buy?

Re: vespa bravo not running well

Nate Lesan /

I put the old filter back on and it seems to be running a bit but but still requires a bit choke inorder to run optimally.

Re: vespa bravo not running well

Nate Lesan /

How do select the jet size? Curentally running a 12/12 dellorto carb with a 43 size main jet and a malossi highflow air filter.

Re: vespa bravo not running well

there ya go nate, details... 43 jet in a 12:12 is too small, u looking for 56 to 66.

Re: vespa bravo not running well

Maybe a new exhaust also?

Re: vespa bravo not running well

Nate, any progress bud?

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account