NC 50 increase performance

I have a 1978 NC 50 and put the big bore kit on essentially making it a 60cc. I added an m/m pipe and mini K&H carburetor. seems small I even added Boysen Power reeds.

Here's the problem it starts and idles just fine, its just slow to get to speed. once it gains momentum the power band kicks in. How do I get quicker response?

Re: NC 50 increase performance

Express NC50 /

How did it run stock? Acceleration and top speed?

Re: NC 50 increase performance

Jim Reagan /

seems about the same except for the late power band it now has.

Re: NC 50 increase performance

Did you re jet the carb? Gotta do that if you change anything.

Re: NC 50 increase performance

Express NC50 /

What was the top speed before?

Re: NC 50 increase performance

Jim Reagan /

I have not re jetted what do you recommend and top speed prior was 28 now 35 so top speed is faster.

Re: NC 50 increase performance

Jim Reagan /

28 to 30

Re: NC 50 increase performance

Express NC50 /

What did the compression measure in lbs. before?

Re: NC 50 increase performance

Jim Reagan /

I have not checked compression

Re: NC 50 increase performance

Express NC50 /

Was there carbon build up in the exhaust port of the original cylinder? Did you clean the oem muffler of carbon? Were the oem rings free in the ring lands or were the rings stuck?

Re: NC 50 increase performance

Jim Reagan /

No there was not build up. rings and piston were fine but I installed a new cylinder and head new piston and rings and new exhaust

Re: NC 50 increase performance

Express NC50 /

Ok Jim, as a base line to compare performance I offer this experience with my own 1979 NC50. I have owned this for over 30 years, and added over 3000 miles to the 3000 miles that were all ready on it. When I first got it running it would go 27-28 miles per hour, over the next almost 30 years the performance had dropped off to only 15mph. A couple of years ago I tried to find out what was wrong with the bike. Because of lack of time to solve the problem and I parked the bike for 2 years. Last fall I decided to either fix it or get ride of it. I checked the timing/point gap and it was ok. I checked the fuel flow to the carb. and it was good. Next a compression test was 145 psi. , also good. In the past I tried cleaning the muffler by baking with a turkey fryer burner, but never ran the bike without the muffler. After the baking it still would go only 15 mph. This time I removed the muffler and tried a different method to clean the muffler after watching a couple of you tube videos. Using a propane torch into the inlet until flames came out the tailpipe and then blowing air into the muffler and doing this until the flames quit coming out of the tailpipe to burn out the carbon plugging the muffler. This time I tried running the bike without the muffler, and it only went 20mph. The next idea was to turn the bike upside down and check the exhaust port. The opening was about the size of your little finger. Next I moved the piston up to cover the port and carefully started cleaning the carbon with a pocket screwdriver and air blower. I uncovered a 1/2 x 1 inch port. Next came a test ride, less the muffler and I was able to reach 35mph one way and the return trip 32mph. Then a second test with the muffler and went 32.5mph on a stock motor. On your bike what size is the carb. venturi? It may be that it is to large and causing the weak mid range because of low speed velocity not pulling fuel through the jet of the carb. I have up graded my bike to 70cc using the DR kit from Treats and the Puch super street cylinder high compression head, with no other changes to the bike, other than replacing the original tires with 70/90-14 IRC brand. No up jetting to the oem carb. and still the stock exhaust. Doing the break in starting last fall and into the winter the air temps were 30-50 degrees and max cylinder head temps were 200-250. On the one 70 degree day so far this year the max was around 350 at wot for one plus miles. Top speed is running 50mph on the flats. The bike has good acceleration from a stop with a strong mid range, I think from the increased cc displacement and small oem carb size. After reaching 35mph it still pulls well to 45mph. Spark plug color is a med to dark brown. Also for all of the 6000+ miles the oil injection is working perfect. I did check my gas mileage after to kit installation and it was 104 mpg . this was with a lot of running wot and cruising 35mph to a slow 25mph because of traffic. Good luck with tuning and stay safe cruising.

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account