Starts but stalls

Kyle Ramsden /

Hey guys I picked up a Tomos targa for cheap and it ran for a summer then sat for a year. It starts and then stalls after a minute. I cleaned the carb out and switched the gas and it still just starts and stalls. If anyone has an idea of what it might be that would be greatly appreciated. I need some direction. Thanks

Re: Starts but stalls

How’s the compression? How fast is the idle (if it idles)?

Could be a leak somewhere as well, that’s why I’d check compression.

Re: Starts but stalls

Condense or its flooded

Re: Starts but stalls

> Kyle Ramsden Wrote:

> -------------------------------------------------------

> Hey guys I picked up a Tomos targa for cheap and it ran for a summer

> then sat for a year. It starts and then stalls after a minute. I cleaned

> the carb out and switched the gas and it still just starts and stalls.

> If anyone has an idea of what it might be that would be greatly

> appreciated. I need some direction. Thanks

ain't that just like a stinkin moped?!?

Re: Starts but stalls

Clean the carb again, really well, sometimes it takes a couple tries to get all the gunk out, clean the tank out and the petcock, and add an inline filter, see if the tank vent is clogged?

Re: Starts but stalls

Without actually seeing the mooed any advice here will be nothing more than guesses albeit some guesses from experience. It can be literally hundreds of possibilities. More info is needed to narrow it down. Under what conditions does it stall? Right away or after hot? On the stand or driving? Tell us

Re: Starts but stalls

Kyle Ramsden /

I haven’t checked compression so I could do that. It starts and runs for a minute and I can give it gas and it revs up and the rear wheel spins and I can even ride it for a second or two. Then it bogs down and dies.

Re: Starts but stalls

> Kyle Ramsden Wrote:

> -------------------------------------------------------

> I haven’t checked compression so I could do that. It starts and runs for

> a minute and I can give it gas and it revs up and the rear wheel spins

> and I can even ride it for a second or two. Then it bogs down and dies.

It honestly almost sounds like you’ve got a clogged petcock/filter/fuel line, and after the bowl is used up it dies out cause the fuel is coming in so slow.

Re: Starts but stalls

agreed with fuel starvation.

Re: Starts but stalls

when cleaning the carb make sure this hole is clear,

in a dellorto 14/12 it's the idle hole

also, is your choke clicking off when you snap it full throttle(edited)

dell_orto_carb_idle_jet_hole.jpg
« Go to Topic — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account