70cc airsal Puch maxi Wont work...

I've recently bought a 70cc Airsal kit. mounted it with no trouble but whatever i do it won't start at all... it ran perfectly before i mounted the cylinder and when i but the standard 50cc back on it runs fine. the moped has good igniton and lets enough fuel into the cylinder.

Im running 15mm bing carburator and a 28mm exhaust.

and a Racing crankshaft in the motor.

Ive tried with "motorstart" spray and fiddling with the ignition timing. but without luck.

i hope some of you "mopedheads" are able to help me. ;)

Re: 70cc airsal Puch maxi Wont work...

Bigger jet? Airleaks? Could be a lot of things.

Re: 70cc airsal Puch maxi Wont work...

Ive tried a lot of different jet sized with both power filter and standard filter. ive replaced all gaskets in motor block. (edited)

Re: 70cc airsal Puch maxi Wont work...

Piston upside down? Piston crown making contact with spark plug electrode at TDC?

Re: 70cc airsal Puch maxi Wont work...

Overpriced Parts /

Don’t run stock type non chamber exhaust or stock air box and make sure arrow on piston is pointed down, run metal mesh filter with circuit or estroil type exhaust 78-80 with 217 atomizer/needle jet jet in real 15mm bing not junk clone,

Don’t fiddle with timing or your magneto read this first :

https://www.mopedarmy.com/wiki/Puch_timing

You should be at 45-50mph not kmph,if you’re not you’re doing something wrong,

Re: 70cc airsal Puch maxi Wont work...

Barry (Bob) Brown /

Try pulling spark plug, and using thumb, check for compression spinning by hand. dribble some fuel in the cylinder and see if it fires that way.

« Go to Topics — end of thread

Want to post in this forum? We'd love to have you join the discussion, but first:

Login or Create Account